Sign in to follow this  
Followers 0
Guest alex_pak

Code Problem

6 posts in this topic

When I read string in file with help command FileReadLine and paste to any window ( for example Notepad Editor) , I see abracadabra if text file is russian.

How can I resolve that problem.

Help me. :whistle:

Share this post


Link to post
Share on other sites



is it the same if you cut & paste text snipets manualy trough notepad?

are all of the characters "translated" wrong?

what are your regional (default) settings?

Share this post


Link to post
Share on other sites

When I read string in file with help command FileReadLine and paste to any window ( for example Notepad Editor) , I see abracadabra if text file is russian.

How can I resolve that problem.

Help me. :whistle:

I think you need to set the font to Cyrillic to display russian characters properly .....

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Sorry for my silent - In Russia was 3 days Holyday. When I try use MSGBOX command , all is ok . My regional settings is Russia. I sink , sam sink wrong when I copy from string variable to clipboard or past from clipboard to text.

By the way , when I copy from Notepad window or Word window, all is ok also.

Share this post


Link to post
Share on other sites

My program still doesn't work . Any advices not help me .

May be it is Windows Problem, I use Windows 2000 Adv Server Eng , but I had try resolve my problen on Wndows 2000 Pro Russian- with out Result.

If samone work with out problem with russian files (or any non english language) on w2k or w9x ansver me , please! :whistle:

Share this post


Link to post
Share on other sites

Maybe it would make sense to request support (or a statement) directly from Jon (Master of A2&3). As he's the webmaster of this forum you can send him a mail.

If that issue occurs under A3 as well (?) it should be in the interest of other A3 developers too. Hey dev guys out there - if A2 isn't dead (haven't seen any official statement regarding this), please have a look on that ...

And btw, it's always a good thing to provide some sample code and basic info to get things done as fast as possible :whistle:

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0