Sign in to follow this  
Followers 0
john123

Terminate script!

4 posts in this topic

Hi everyone!

I have a script with GUI, while run script, I use hot key to exit script. The script exit but it still run in task manager.

My hot key:

HotKeySet("^!x",_quit())

;script here

Func _quit()
  Exit 0
EndFunc

Please help me how to kill it in task manager.

Thanhks for your help.

Share this post


Link to post
Share on other sites



Hi everyone!

I have a script with GUI, while run script, I use hot key to exit script. The script exit but it still run in task manager.

My hot key:

HotKeySet("^!x",_quit())

;script here

Func _quit()
  Exit 0
EndFunc

Please help me how to kill it in task manager.

Thanhks for your help.

Try taking away the 0 after Exit, not sure what it's for. Also, since I'm assuming this is psuedocode (Did I spell that right?), try taking a look at your code and make sure there's no long or looping functions that are going on when you try to exit.

For those who are asking questions, look in the help file first. I'm tired of people asking stupid questions about how to do things when 10 seconds in the help file could solve their problem.[quote name='JRowe' date='24 January 2010 - 05:58 PM' timestamp='1264381100' post='766337'][quote name='beerman' date='24 January 2010 - 03:28 PM' timestamp='1264372082' post='766300']They already have a punishment system for abuse.[/quote]... and his his name is Valik.[/quote]www.minikori.com

Share this post


Link to post
Share on other sites

Hi everyone!

I have a script with GUI, while run script, I use hot key to exit script. The script exit but it still run in task manager.

My hot key:

HotKeySet("^!x",_quit())

;script here

Func _quit()
  Exit 0
EndFunc

Please help me how to kill it in task manager.

Thanhks for your help.

This script doesn't show your problem so you will have to do better and supply an example snippet to demonstrates your reported issue.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I've been seeing a possible problem with Exit lately and I'm not sure yet if the problem is at my end or if it's a possible bug in AutoIt. Exit has been around for a long time and as far as I know there have been no changes to it so I don't see where it would suddenly develop a bug.

On the other hand, I'm surprised your code works at all if you wrote it as shown in your first post.

it should have been

HotKeySet("^!x","_quit")

;script here

Func _quit()
  Exit 0
EndFunc

George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0