Sign in to follow this  
Followers 0
Hypertrophy

running script with warnings

3 posts in this topic

whenever i check my script in scite using the built-in tools i got a ton of warnings (42) with all of them saying certain variables were "possibly used before declaration" should i worry about this? i also have includes that use variables in my maint script so can this be the cause? appreciate help. >_

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

You have to declare first the variables, if you tray to compile you maybe get an error.

You can do this

Dim $variable1, $variable2, $variable3, etc.
[The rest of the script]
Edited by PAULOGARCIA2005

Share this post


Link to post
Share on other sites

whenever i check my script in scite using the built-in tools i got a ton of warnings (42) with all of them saying certain variables were "possibly used before declaration" should i worry about this?

If you keep ignoring the warnings and run the scripts anyway, the Americans will wind up with all three branches of their government under one-party rule... oh, wait...

...just couldn't help yourself, could you?!

>_<


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0