Jump to content
Sign in to follow this  
nicholassolutions

Strange AITv3 file association problem

Recommended Posts

nicholassolutions

Hi all,

I have a strange problem, and I'm wondering if anyone can help me figure out what's wrong. I've got AutoIT on my laptop running WinXP, and up until a few days ago, everything was working fine. Now all of a sudden when I try to run .au3 srcipts, I get errors like this:

C:\path\to\script\srciptname.au3 is not a valid Win32 application

I tried uninstalling and reinstalling AutoIT, but that didn't help. Then I tried going into the properties for one of my scripts, and specifically selecting 'open with' AutoIT3.exe. That doesn't help either, and the strange thing is, when I select AutoIT3.exe, when I look back in the "Open With" menu, instead of showing AutoIT3, it shows 'program' with the same icon that gets used for .bat files. :D

When I run AutoIT3.exe and select the script I want to run, it works ok. I'm pretty sure this is just some stupid problem with a registry value or something, but for the life of me I can't seem to figure out what it is.

Any ideas would be REALLY appreciated -- :) I need my AutoIT!!

Edited by nicholassolutions

Share this post


Link to post
Share on other sites
quaizywabbit

Control panel > Folder Options> File Types> scroll down to .au3 and highlight it.

You can then change what program opens your scripts ( Mine open with SciTe)


[u]Do more with pre-existing apps![/u]ANYGUIv2.8

Share this post


Link to post
Share on other sites
nicholassolutions

Control panel > Folder Options> File Types> scroll down to .au3  and highlight it.

That's equivalent to what I was doing...unfortunately I still had the same problem -- thanks for the suggestion though, it got me thinking some more, and I was able to solve the problem by just making a copy of autoit3.exe, and pointing my au3 files to that instead....strange...oh well, at least it works. Thanks again for the help.

Share this post


Link to post
Share on other sites
Smed

just a guess, check HKEY_CLASSES_ROOT\Applications\AutoIt3.exe\shell\Run\Command

in the registry and see what it says.


601DisengageEnd Program

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×