Sign in to follow this  
Followers 0
choto

Can v3 do that with other program window....

6 posts in this topic

This is my first post, before anything, hi everyone.

My questions...

I want to make a simple gui for a little origram I made, it is a opengl tool, that shows a opengl window,well, two thing:

-Can I have locked the application window with my gui window, I want to say, if a move the gui window, the other application window moves with it.

- Can I insert any way that window inside my gui window, I want to say, can autoit v3 show some way other application winow inside the gui window....

thanks.

Share this post


Link to post
Share on other sites

You can make your GUI appear to be 'embedded' into the other application window.

read through this thread....maybe this will work for you

ANYGUI.au3

there are ways to do what you originally asked... I just haven't needed to do it that way....


[u]Do more with pre-existing apps![/u]ANYGUIv2.8

Share this post


Link to post
Share on other sites

-Can I have locked the application window with my gui window, I want to say, if a move the gui window, the other application window moves with it.

<{POST_SNAPBACK}>

I have gotten ANYGUI.au3 to work for me and attach GUI elements inside an existing parent control, but I have also been wondering about this solution.

I've seen RoboForm do this -- attach a GUI to the bottom of Internet Explorer that is outside the parent and moves and iconifies with it. I'd love to be able to do this as well as what ANYGUI does because I then wouldn't have to worry about control geometry or asthetics inside the existing parent.

I'd love to see some ideas/hints on how to approach this...

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

The application I made is a little opengl viewer, I want to use autoit via bridge files like a gui for that app.

I take a look to ANYGUI.au3.

htanks.

Share this post


Link to post
Share on other sites

I've seen RoboForm do this -- attach a GUI to the bottom of Internet Explorer that is outside the parent and moves and iconifies with it.  I'd love to be able to do this as well as what ANYGUI does because I then wouldn't have to worry about control geometry or asthetics inside the existing parent.

I'd love to see some ideas/hints on how to approach this...

Dale

<{POST_SNAPBACK}>

so your after being able to "Dock" your GUI to the edge of another window, similar to the way Winamp does....right? so everything moves as a unit..

[u]Do more with pre-existing apps![/u]ANYGUIv2.8

Share this post


Link to post
Share on other sites

so your after being able to "Dock" your GUI to the edge of another window, similar to the way Winamp does....right? so everything moves as a unit..

<{POST_SNAPBACK}>

Exactly.

Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0