Sign in to follow this  
Followers 0
Dobs78

Ran into a brick wall

9 posts in this topic

I've automated the installation of UltraVNC 1.0.6.4 without any problems. Where I'm running into the brick wall is when the 'Ultr@VNC Server Property Page' window opens, you're prompted to change the 'VNC Password'. During the manual installation, once I get to this point, all I have to do is start typing and the password changes, however, I'm unable to automate the entry of this password.

I've searched the forums and the Help/Online Documentation for the last 3 hours and have tried the following:

WinWaitActive("Ultr@VNC Server Property Page", "")

Send("password", 1)

WinWaitActive("Ultr@VNC Server Property Page", "")

ControlFocus("Ultr@VNC Server Property Page", "", "Edit5")

ControlSend("Ultr@VNC Server Property Page", "", "Edit5", "password")

WinWaitActive("Ultr@VNC Server Property Page", "")

ControlFocus("Ultr@VNC Server Property Page", "", "Edit5")

ControlSend("Ultr@VNC Server Property Page", "", "[iD:1009]", "password")

WinWaitActive("Ultr@VNC Server Property Page", "")

ControlFocus("Ultr@VNC Server Property Page", "", "Edit5")

ControlSend("Ultr@VNC Server Property Page", "", "1009", "password")

WinWaitActive("Ultr@VNC Server Property Page", "")

ControlSetText("Ultr@VNC Server Property Page", "", "Edit5", "password")

Here's the Summary from the Window Info if it'll help you help me:

>>>> Window <<<<

Title: Ultr@VNC Server Property Page

Class: #32770

Position: 544, 267

Size: 591, 488

Style: 0x94CA08CC

ExStyle: 0x00010101

Handle: 0x000800A2

>>>> Control <<<<

Class: Edit

Instance: 5

ClassnameNN: Edit5

Advanced (Class): [CLASS:Edit; INSTANCE:5]

ID: 1009

Text:

Position: 99, 219

Size: 111, 21

ControlClick Coords: 59, 13

Style: 0x500100A0

ExStyle: 0x00000204

Handle: 0x00030158

>>>> Mouse <<<<

Position: 705, 521

Cursor ID: 0

Color: 0xFFFFFF

>>>> StatusBar <<<<

>>>> Visible Text <<<<

Incoming Connections

Accept Socket Connections

Display Number or Ports to use:

Display

0

Ports

Main:

5900

Auto

Http:

5800

Enable JavaViewer (Http Connect)

Allow Loopback Connections

LoopbackOnly

When Last Client Disconnects

Do Nothing

Lock Workstation (W2K)

Logoff Workstation

Keyboard && Mouse

Disable Viewers inputs

Disable Local inputs

Japanese

Query on incoming connection

Display Query Window

Timeout:

10

seconds

Default action:

Refuse

Accept

Multi viewer connections

Disconnect all existing connections

Keep existing connections

Refuse the new connection

Refuse all new connection

Authentication

VNC Password:

Require MS Logon (User/Pass./Domain)

New MS Logon (supports multiple domains)

Configure MS Logon Groups

Misc.

Remove Aero (Vista)

Remove Wallpaper for Viewers

Enable Blank Monitor on Viewer Request

Enable Alpha-Blending Monitor Blanking

Capture Alpha-Blending

DisableTrayIcon

Forbid the user to close down WinVNC

Default Server Screen Scale:

1 /

1

File Transfer

Enable

User impersonation (for Service only)

DSM Plugin

Use :

Config.

Logging

Log debug infos to the WinVNC.log file

Path:

C:\Program Files\UltraVNC

&OK

&Apply

&Cancel

>>>> Hidden Text <<<<

Auto

Disable clients options in tray icon menu

Log to video

Clear avi encoder

I just can't seem to get the password changed. I'm willing to bet it's something completely dumb I'm missing/overlooking. Any help is appreciated. Now that I look at this, is the '@' in the Ultr@VNC causing an issue? Just spit balling now ...

Share this post


Link to post
Share on other sites



Try changing

ControlSetText("Ultr@VNC Server Property Page", "", "Edit5", "password")

to

ControlSetText("Ultr@VNC Server Property Page", "", "[CLASS:Edit; INSTANCE:5]", "password", 1)


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Try changing

to

I gave it a spin, still the same result, it's pausing before the password can be changed. I did notice something though, and not sure if it will help, but I noticed that the Admin Properties screen I'm trying to work with opens after the install process (UltraVNC.exe) ends. I moved my ProcessWaitClose above the admin config part of my script and that doesn't change anything. winvnc.exe is what's launching this admin properties window, is there additional code I need to add to adjust for winvnc.exe launching this window for what I'm trying to do or ..... ?

Share this post


Link to post
Share on other sites

I gave it a spin, still the same result, it's pausing before the password can be changed. I did notice something though, and not sure if it will help, but I noticed that the Admin Properties screen I'm trying to work with opens after the install process (UltraVNC.exe) ends. I moved my ProcessWaitClose above the admin config part of my script and that doesn't change anything. winvnc.exe is what's launching this admin properties window, is there additional code I need to add to adjust for winvnc.exe launching this window for what I'm trying to do or ..... ?

Since 1.0.4 and later version, all Admin Properties setting are saved inside the file ultravnc.ini at the same folder as winvnc.exe

Share this post


Link to post
Share on other sites

Since 1.0.4 and later version, all Admin Properties setting are saved inside the file ultravnc.ini at the same folder as winvnc.exe

Yep, found that out today, saves the pass in a 128-bit hex key.

Share this post


Link to post
Share on other sites

Bumping this post. Of all the software installations I've completed, this remains that last one due to this stupid VNC Password input box. The only conclusion I can come up with as to why it's not working is that there's an @ symbol in the window title. Again, if anyone could help me with this, it will be greatly appreciated. Adding to my initial post, I've tried putting the window title into a variable and I get the same result. For some reason AutoIt is just not seeing the window as active, even with WinActivate. All information is provided above in my original post.

Thanks in advance for any help.

Share this post


Link to post
Share on other sites

Bumping this post. Of all the software installations I've completed, this remains that last one due to this stupid VNC Password input box. The only conclusion I can come up with as to why it's not working is that there's an @ symbol in the window title. Again, if anyone could help me with this, it will be greatly appreciated. Adding to my initial post, I've tried putting the window title into a variable and I get the same result. For some reason AutoIt is just not seeing the window as active, even with WinActivate. All information is provided above in my original post.

Thanks in advance for any help.

why not setup one box, then do the install and copy the ini file over to the other ones? assuming that the password will be the same across all the machines.

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

why not setup one box, then do the install and copy the ini file over to the other ones? assuming that the password will be the same across all the machines.

We currently do that. However, in instances were McAfee updates, every now and then it will block/delete VNC thus forcing a re-install of the software, hence why I am automating it. Our employee base isn't the most .... computer savvy people.

Edited by Dobs78

Share this post


Link to post
Share on other sites

We currently do that. However, in instances were McAfee updates, every now and then it will block/delete VNC thus forcing a re-install of the software, hence why I am automating it. Our employee base isn't the most .... computer savvy people.

Set all of your titles (in the script from "Ultr@VNC Server Property Page" to "VNC Server Property Page".

Then add the line Opt("WinTitleMatchMode", 2) to the top of the script.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0