Jump to content
Sign in to follow this  
vi6ora

Help with my script

Recommended Posts

vi6ora

Hi. Can someone tell me what is wrong with my script. Here is the code:

$Form1 = GUICreate("[AGMT]Aion GameMaster Tool by Crowen V 1.10", 711, 546, 190, 121)
GUISetBkColor(0x1A1A1A)
$Pic1 = GUICtrlCreatePic("C:\Documents and Settings\Administrator\Desktop\gmtooldesign copy.jpg", 0, 8, 708, 508, 0)
$Group1 = GUICtrlCreateGroup("General Commands", 8, 320, 193, 201)
GUICtrlSetBkColor(-1, 0x00FFFF)
$Label1 = GUICtrlCreateLabel("Spawn:", 80, 432, 40, 17)
GUICtrlSetBkColor(-1, 0xC0C0C0)
$Input1 = GUICtrlCreateInput("Spawn ID", 40, 456, 121, 20, BitOR($ES_AUTOHSCROLL,$ES_NUMBER), 0)
GUICtrlSetFont(-1, 8, 800, 0, "OCR A Std")
GUICtrlSetColor(-1, 0x808000)
$Label2 = GUICtrlCreateLabel("Move To:", 72, 336, 50, 17)
GUICtrlSetBkColor(-1, 0xC0C0C0)
$Input2 = GUICtrlCreateInput("Map ID", 40, 360, 121, 21, BitOR($ES_AUTOHSCROLL,$ES_NUMBER))
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
GUICtrlSetColor(-1, 0x008080)
$Button1 = GUICtrlCreateButton("Move To", 64, 392, 75, 25, 0)
GUICtrlSetFont(-1, 10, 400, 0, "MS Sans Serif")
GUICtrlSetColor(-1, 0x008080)
$Button2 = GUICtrlCreateButton("Spawn", 64, 488, 75, 25, 0)
GUICtrlSetFont(-1, 10, 400, 0, "MS Sans Serif")
GUICtrlSetColor(-1, 0x008080)
GUICtrlCreateGroup("", -99, -99, 1, 1)
$Group2 = GUICtrlCreateGroup("Lists", 216, 320, 377, 201)
$Edit1 = GUICtrlCreateEdit("", 248, 360, 185, 153)
GUICtrlSetData(-1, StringFormat("110010000 1313 1512 570\r\n110010000 1756 2020 550\r\n210020000 300 2700 700\r\n210030000 1645 1500 120\r\n210040000 1045 2768 130\r\n210040000 2445 368 420\r\n220010000 500 2768 300\r\n220020000 295 2200 451\r\n220030000 1700 2000 700\r\n220030000 2545 1568 330\r\n220040000 345 368 290\r\n220040000 600 2600 450"))
$Label3 = GUICtrlCreateLabel("Map ID's", 264, 336, 84, 22)
GUICtrlSetFont(-1, 12, 800, 2, "Prestige Elite Std")
GUICtrlSetColor(-1, 0xFFFF00)
$Label4 = GUICtrlCreateLabel("NPC ID's", 456, 336, 84, 22)
GUICtrlSetFont(-1, 12, 800, 2, "Prestige Elite Std")
GUICtrlSetColor(-1, 0xFF00FF)
$List2 = GUICtrlCreateList("", 440, 360, 121, 149)
GUICtrlCreateGroup("", -99, -99, 1, 1)
GUISetState(@SW_SHOW)


While 1
    $nMsg = GUIGetMsg()
    Select
        Case $nMsg = $GUI_EVENT_CLOSE
            Exit
        Case $nMsg = $Button1
            MoveTo()
        Case $nMsg = $Button2
            Spawn()         
    EndSelect
WEnd

Func MoveTo()
    ControlSend("AION Client", "", "Edit1", "{ENTER}")
    ControlSend("AION Client", "", "Edit2", "//moveto" & GuiCtrlRead($Input2))
EndFunc

Func Spawn()
    ControlSend("AION Client", "", "", "//spawn" & GuiCtrlRead($Input1))
EndFunc

Thanks in advance.

Share this post


Link to post
Share on other sites
Hawkwing

Could you be more descriptive? Like, maybe saying what the problem is. I don't know about everyone else on this forum, but I don't like looking through code trying to find an error when I don't even know what I'm looking for.


The Wheel of Time turns, and Ages come and pass, leaving memories that become legend. Legend fades to myth, and even myth is long forgotten when the Age that gave it birth comes again.

Share this post


Link to post
Share on other sites
vi6ora

Well its not 500 lines script. The problem is that the controlsend function is not working.

Share this post


Link to post
Share on other sites
Hawkwing

Sorry if I seem impatient with people newer to the forum, but that code seems to be missing some includes, and it also uses picture files that I don't have. First I would check if the control ID is correct with the window info tool, I think most, if not all control IDs are numerical.


The Wheel of Time turns, and Ages come and pass, leaving memories that become legend. Legend fades to myth, and even myth is long forgotten when the Age that gave it birth comes again.

Share this post


Link to post
Share on other sites
vi6ora

Still not working. The info tool doesnt give me the control ID.

Share this post


Link to post
Share on other sites
WannaLearnPls

Could you be more descriptive? Like, maybe saying what the problem is. I don't know about everyone else on this forum, but I don't like looking through code trying to find an error when I don't even know what I'm looking for.

Indeed.. I'm new around here, but I completely agree with you

Well its not 500 lines script. The problem is that the controlsend function is not working.

Doesn't matter the amount of lines.. If you don't specify what problem you got with your code, how are we supposed to know??

Still not working. The info tool doesnt give me the control ID.

Anyhow, if you are trying to use this on a game or application with security, such as GameGuard, you won't be able to get the Control ID just like that... There might be a way, but I don't know it since I didn't bother to look for that yet.. And for what I've seen it's not likely you will get your answer on these forums as well >_<

Share this post


Link to post
Share on other sites
vi6ora

yes it hase nProtect game guard is there any way to disable it? Or any way to get it working?

Share this post


Link to post
Share on other sites
WannaLearnPls

if you could disable it just like that you would be able to make hacks and such as well... no fun >_

Share this post


Link to post
Share on other sites
vi6ora

Ok i managed to dissable the GG, but still can do it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.