Sign in to follow this  
Followers 0
Pringles

Help me please...

10 posts in this topic

Help me please, I have an application, rather the game, so now when I emulate keyboard without pauses(While 1=1 Send("1") Wend)

, all the emulated pressing OK, but if you make a pause(While 1=1 Send("1") Sleep(1000) Wend), then the game 1-3 emulated only pressing and all, but if you press on the keyboard any key, the game again emulated only 1-3 and all pushing and so forth. I tried the command Send,SendRaw,SendPlay,SendInput in AHK but this does not help. Thanks

And I from Russia, and use http://translate.google.com

Share this post


Link to post
Share on other sites



Please put the code in code tags and format it correctly. It makes it eraser to see what is going on. While 1 = 1 does not make sense.


Post your code because code says more then your words can. SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y. Use Opt("MustDeclareVars", 1)[topic="84960"]Brett F's Learning To Script with AutoIt V3[/topic][topic="21048"]Valuater's AutoIt 1-2-3, Class... is now in Session[/topic]Contribution: [topic="87994"]Get SVN Rev Number[/topic], [topic="93527"]Control Handle under mouse[/topic], [topic="91966"]A Presentation using AutoIt[/topic], [topic="112756"]Log ConsoleWrite output in Scite[/topic]

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

The code tags are the least of the problem to see what is going on. Could you try rephrasing your question. I don't quite understand your problem is. And the while 1=1 is simply a statement which always returns true, so it is an infinite loop.

Edited by qazwsx

Share this post


Link to post
Share on other sites

The code tags are the least of the problem to see what is going on. Could you try rephrasing your question. I don't quite understand your problem is. And the while 1=1 is simply a statement which always returns true, so it is an infinite loop.

I understand while 1 = 1, just have never seen that done. It just really strange

Post your code because code says more then your words can. SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y. Use Opt("MustDeclareVars", 1)[topic="84960"]Brett F's Learning To Script with AutoIt V3[/topic][topic="21048"]Valuater's AutoIt 1-2-3, Class... is now in Session[/topic]Contribution: [topic="87994"]Get SVN Rev Number[/topic], [topic="93527"]Control Handle under mouse[/topic], [topic="91966"]A Presentation using AutoIt[/topic], [topic="112756"]Log ConsoleWrite output in Scite[/topic]

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

I understand that the marks while 1=1, so it should be, and I so wish that the script was endless, and I need to spam one button, but that is the problem that spam works just fine, but spam with a pause of 1 second is not working script emulates the press of only 1-2 times! While in the notebook and it works great, it is in the game as I understand, but what it I do not know

Edited by Pringles

Share this post


Link to post
Share on other sites

You still do not make any sense. Do you want to send a keypress every 1 sec infinitely?

Dim $i=1

While $i<>0
Send(key)
Sleep(1000)
Wend

ps. i get it you're from Russia but what you have asked is in English. Translating english to english will not help. :/

you really need to post the code.

pps. There may be a restriction in the game where if it detects keystrokes being sent at exact intervals (humans can't do it, its a bot detection tactics), it stops accepting the keystrokes. If this is the case, just make an array with contents from 900 to 1100 and take those as the sleep intervals and keep cycling through them.

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

I really don't understand what u r doing here..

1) U say you want to "spam" a button..

2) In ur script u have added a line

Send("1")
..

How 1) and 2) go with each other??? Not sure..

@Rishav,

To avoid bot detection you can also use

sleep(random(990,1100))
Edited by Manjish

[font="Garamond"]Manjish Naik[/font]Engineer, Global Services - QPSHoneywell Automation India LimitedE-mail - Manjish.Naik@honeywell.com

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

I call it a forum for English because few people with the Russian and, generally, few people enjoy autoIT. Random does not help, I tried... My source minicode:

While 1=1

Send("1")

Sleep(1000)

Wend

Edited by Pringles

Share this post


Link to post
Share on other sites

I really don't understand what u r doing here..

1) U say you want to "spam" a button..

2) In ur script u have added a line

Send("1")
..

How 1) and 2) go with each other??? Not sure..

@Rishav,

To avoid bot detection you can also use

sleep(random(990,1100))

Thanks for making me feel stupid. >_<

forgot that we have a random function. sheesh.

@pringles, i don't know how you are using 1=1. you have to use a variable. trying using the snippet i posted.

is your code something like this?

While $i=1
Send($i)
Sleep(1000)
Wend

Share this post


Link to post
Share on other sites

@Rishav

Not meaning to make anyone feel stupid.. >_<

what's the complication in using a variable as a constant?? $i=1..

Why not just write in simple terms..

while 1

@Pringles,

you still haven't answered my question. Can't help you, if I don't understand what you want!! :(


[font="Garamond"]Manjish Naik[/font]Engineer, Global Services - QPSHoneywell Automation India LimitedE-mail - Manjish.Naik@honeywell.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0