Sign in to follow this  
Followers 0
engine

Integrating AutoIt with your own version of SciTE

15 posts in this topic

Through AutoIt I discovered SciTE. And I love it! So I want to use it for everything else. Not just to edit au3 scripts. So I want to install the SciTE msi and get it to work as SciTE4AutoIt does. And if I get that I don't need to install SciTE executable with AutoIt. So there should be an option not to install SciTE within AutoIt installer and instead integrating it with an existing or future SciTE installation. While we don't get to this ideal, what can be done?

Thanks.


My contributions:Local account UDF Registry UDFs DriverSigning UDF Windows Services UDF [url="http://www.autoitscript.com/forum/index.php?showtopic=81880"][/url]

Share this post


Link to post
Share on other sites



I use this installer -> http://opensource.ebswift.com/SciTEInstaller/

However support for AutoIt is limited. And even with the properties files from SciTE4AutoIt site I don't get the same functionality as I get with AutoIt's own SciTE.


My contributions:Local account UDF Registry UDFs DriverSigning UDF Windows Services UDF [url="http://www.autoitscript.com/forum/index.php?showtopic=81880"][/url]

Share this post


Link to post
Share on other sites

AutoIt doesn't include the full version of Scite4AutoIt either. What I generally do is use the AutoIt SFX file, Extract the files with Universal Extractor and then Just copy what I want to The AutoIt3 Folder. Then I do pretty much the same for installing Scite4AutoIt.

I do agree that the AutoIt installer should have more optional components though and the lite version of Scite could be optional.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Should be easy to accomplish what you want. Just update your own SciTE installation with whatever you want and update the au3 registry settings to point to your own version of SciTE.

If you want it to work as the Full version as the SciTE4AutoIt3 installer sets things up you will have to invest time in incorporating all the stuff in your own setup. Even that is not that difficult when you know how things work.

Everything is available in a ZIP file on the downloadpages.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Should be easy to accomplish what you want. Just update your own SciTE installation with whatever you want and update the au3 registry settings to point to your own version of SciTE.

If you want it to work as the Full version as the SciTE4AutoIt3 installer sets things up you will have to invest time in incorporating all the stuff in your own setup. Even that is not that difficult when you know how things work.

Everything is available in a ZIP file on the downloadpages.

Jos

I edited the properties files as you suggested. And everything appears to be fine, except when I type keywords that start by a cardinal like

#Include
#NoTrayIcon

In this case I am not getting the usual tips from "au3.api".

I use this msi installer -> http://opensource.ebswift.com/SciTEInstaller/

The other files are on the file attached. Where is also an AutoIt script that installs the msi and does all the copying and configuration. You need the Registry UDFs from my signature to run the script.

If you could help me to get this working, that would be awesome.

Thanks.


My contributions:Local account UDF Registry UDFs DriverSigning UDF Windows Services UDF [url="http://www.autoitscript.com/forum/index.php?showtopic=81880"][/url]

Share this post


Link to post
Share on other sites

I have no issue trying to help you but please don't expect me to start installing everything you use bit by bit and make it work. In that case you should use my SciTE4AutoIt3 installer as that contains a total working version and use that as the base installer of you SciTE installation. :)

Anyways, you need to use the proper au3.properties files that we supply and contains:

autocomplete.au3.ignorecase=1
autocomplete.au3.start.characters=$(chars.alpha)$(chars.numeric)$_@#
word.characters.$(au3)=$(chars.alpha)$(chars.numeric)$(chars.accented).$_@#

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

After installing newest AutoIt version 3.3.2.0 and replacing "au3.keywords.properties" and "au3.api", now I have new small problem. Keywords that start by a cardinal like:

#RequireAdmin
#NoTrayIcon

don't show up in colors. Just regular black. Everything else appears to be working fine.

Can someone help, please?

Thanks in advance.


My contributions:Local account UDF Registry UDFs DriverSigning UDF Windows Services UDF [url="http://www.autoitscript.com/forum/index.php?showtopic=81880"][/url]

Share this post


Link to post
Share on other sites

Thanks for your reply.

The problem is that the AutoIt version of SciTE only has those two files besides the SciTE executable. So that method won't help. Unless an updated version of SciTE4AutoIt is released soon.


My contributions:Local account UDF Registry UDFs DriverSigning UDF Windows Services UDF [url="http://www.autoitscript.com/forum/index.php?showtopic=81880"][/url]

Share this post


Link to post
Share on other sites

After installing newest AutoIt version 3.3.2.0 and replacing "au3.keywords.properties" and "au3.api", now I have new small problem. Keywords that start by a cardinal like:

#RequireAdmin
#NoTrayIcon

don't show up in colors. Just regular black. Everything else appears to be working fine.

Can someone help, please?

Thanks in advance.

To see what is wrong I would need to see the following files:

SciTEGlobal.properties

au3.properties

au3.keywords.properties

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Thanks once again for your help.

Here it is ->

Works fine for me with your files.

... but I know why it doesn't work. Just remembered we made an update to our version of SciTE to lift the limit of a single Properties file from 60000 to 100000 to allow for a bigger au3.keywords.properties files.

So the only thing you can do is to split the au3.keywords.properties file in 2 files and include them both in au3.properties.

import properties\au3.keywords
import properties\au3.keywords2

Jos ;)


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0