Jump to content
Sign in to follow this  
EscapeTheFate

Submitting a 'button' in IE

Recommended Posts

EscapeTheFate

solved

Edited by EscapeTheFate

Share this post


Link to post
Share on other sites
EscapeTheFate

solved

Edited by EscapeTheFate

Share this post


Link to post
Share on other sites
Bert

Have you tried to access it by the index value?

#include <IE.au3> 
$oIE = _IECreate ("http://www.autoitscript.com") 
$oElements = _IEFormElementGetCollection ($oIE) 
MsgBox(0, "Elements Info", "There are " & @extended & " elements on this page") 
For $oElement In $oElements     
   MsgBox(0, "Element Info", $oElement.name) 
Next

This example shows how to get the list of elements. It puts it in an array. Use the array index value to access the control.

Share this post


Link to post
Share on other sites
EscapeTheFate

solved

Edited by EscapeTheFate

Share this post


Link to post
Share on other sites
EscapeTheFate

solved

Edited by EscapeTheFate

Share this post


Link to post
Share on other sites
EscapeTheFate

solved thank you

Edited by EscapeTheFate

Share this post


Link to post
Share on other sites
EscapeTheFate

solved

Edited by EscapeTheFate

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×