Sign in to follow this  
Followers 0
mmahima

Unable to work on Firefox using FF.au3 functions

7 posts in this topic

Hi all,

I try to use the functions, which are given in the below URL, for working on autoit and firefox.

http://english.documentation.ff-au3.thorsten-willert.de/

Autoit is displaying the following error messages

__FFSend: try{FFau3 != null?1:0}catch(e){'_FFCmd_Err';};

__FFWaitForRepl ==> Timeout: 12ms > 10000ms $iTimeOut

__FFRecv:

__FFWaitForRepl ==> Timeout: 12ms > 30000ms $iTimeOut

_FFIsConnected ==> Socket Error: 1640

Could any one help me, in clicking on a link in firefox application.

Thanks in Advance.

Share this post


Link to post
Share on other sites



Did you install the required plug-in to your copy of Firefox? Without it, FF.au3 doesn't work.

:(


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

I didn't install any plug-in, can you share the path of plug-in, so that i can install it

Share this post


Link to post
Share on other sites

You are kidding right? The bit about not being able to find the plugin. Its like in big bold writing for each thread allocated for it...

http://www.autoitscript.com/forum/index.php?showtopic=95595

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Now i have installed it,

It is still giving the following

__FFStartProcess: ""C:\Program Files\Mozilla Firefox\firefox.exe" -new-window "about:blank" -repl 4242

_FFConnect: OS: WIN_XP WIN32_NT 2600 Service Pack 3

_FFConnect: AutoIt: 3.3.6.0

_FFConnect: FF.au3: 0.6.0.1b-3

_FFConnect: IP: 127.0.0.1

_FFConnect: Port: 4242

_FFConnect: Delay: 2ms

_FFConnect: Socket: 1644

_FFLoadWait: .

__FFWaitForRepl ==> Timeout: 10031ms > 10000ms $iTimeOut

__FFWaitForRepl ==> Timeout: 30031ms > 30000ms $iTimeOut

.

__FFWaitForRepl ==> Timeout: 30030ms > 30000ms $iTimeOut

.

__FFWaitForRepl ==> Timeout: 30030ms > 30000ms $iTimeOut

when i execute the below code

#include <FF.au3>

If _FFIsConnected() Then

_FFOpenURL("http://www.ip-adress.com/") ; open a page

Sleep(3000)

_FFDisConnect() ; close the connection

Else

MsgBox(64, "", "Can't connect to FireFox!")

EndIf

Can I increase the Time delay, as the script is showing a message "TimeOut:......."

Edited by mmahima

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

You are kidding right? The bit about not being able to find the plugin. Its like in big bold writing for each thread allocated for it...

http://www.autoitscript.com/forum/index.php?showtopic=95595

I have installed the AddOn & activated the MozRepl using Tools > MozRepl > Activate on StartUp

Do i need to do, any other thing other this.

I am still unable to work on this functions.

I tried with Firefox 3.3.6 and 2.0.0.1

Could any one help me regarding this.

Edited by mmahima

Share this post


Link to post
Share on other sites

Wrong forum. You might find more users of the FF.au3 UDF in General Help and Support forum.

This is this Graphical User Interface (GUI) forum and FF doesn't have much to do with that.

:(


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0