Jump to content
Sign in to follow this  
WundaGirl

Button does not show unless you move the mouse over

Recommended Posts

WundaGirl

Anyone seen an issue where when they execute their script, a button does not display unless I move my mouse over its location?

Share this post


Link to post
Share on other sites
Remnant

personally no, try uploading your script.

Share this post


Link to post
Share on other sites
DW1

Sure, this can happen when you lay the GUI out with overlapping controls... For example (this creates 100 buttons, but none can be seen due to the label sitting over the top of them... until you mouse over):

#include <GUIConstantsEx.au3>
$GUI = GUICreate("App", 500, 500, @DesktopWidth / 2)
$i = 0
Dim $Button[1]
For $a = 0 To 450 Step 50
    For $b = 0 To 450 Step 50
        $i += 1
        ReDim $Button[$i]
        $Button[$i - 1] = GUICtrlCreateButton('B ' & $i, $a, $b, 50, 50)
    Next
Next
$Label = GUICtrlCreateLabel('', 0, 0, 500, 500)
GUISetState()

While 1
    $nMsg = GUIGetMsg()
    Switch $nMsg
        Case $GUI_EVENT_CLOSE
            Exit
    EndSwitch
    Sleep(10)
WEnd
Edited by danwilli

Share this post


Link to post
Share on other sites
WundaGirl

Just realized the size entries for the label text was overlapping my button. Although the text itself was no where near my button, the size allocations for the label text caused problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.