Sign in to follow this  
Followers 0
TinyHacker

Old scripts don't work with the new version!!

11 posts in this topic

Hello guys! this is my first subject here.. i'm using AutoIt sice 2 years and i swear that i've just knew that there is a new version  :mellow::P ... also i dont speak english.. but i like this program and i made many many great scripts.. but my question is ...:

when i run the old scripts with the new version it doesn't work! i mean that " $ES_AUTOVSCROLL + $WS_VSCROLL + $ES_MULTILINE  + $WS_EX_TOOLWINDOW and .......... " is not working, and all the scripts that i have , have these command! so?! can i have a converter? or what? just to make the old scripts work again  :party: ! Oh please!

thanks  :party: and forgive me if i made linguistic mistakes  Posted Image

Share this post


Link to post
Share on other sites



TinyHacker,

Welcome to the AutoIt forum. :mellow:

Which AutoIt version are you using?

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

Oh thank u "Melba23 "  Posted Image

I was using v 3.1.1.0 as an old one.. but yesterday i've downloaded v 3.3.6.1 ...  :mellow:

so what can i do now? i really work more than 5 hours a day on AutoIt, and all what i mad is with the old version, i liked the new one it's SUPER!! but i also can't leave my scripts like that!

I really thank u for ur reply bro!

Share this post


Link to post
Share on other sites

TinyHacker,

That is a very big jump you are making (3.1.1 was released on 7/04/2005) - there have been enormous changes in AutoIt syntax and functions since then. :mellow:

The first place to start is by reading this topic which explains the major changes brought in by 3.2.12 - perhaps most importantly the need for many more include files to be specified.

Then I suggest that you read through the "History" page in the Help file to see how much has changed since then.

Now for the really bad news. :P I am afraid that you are in for a great deal of work changing your scripts - I would suggest that rewriting them from scratch might well be the best way to go.

Sorry to be the bearer of such unpleasant news, but you really should have updated more often. Five years is an age in IT terms - AutoIt has changed out of almost all recognition since you started using it.

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

From the time v3.11 was out, there has been 95, 98, 98SE, XP, Vista, Seven, plus several service packs. There are rumors that an intermediate version was released around the millenium but after careful checking it turned out to be untrue.

Of course I'm joking but Melba23 is right in that you really should keep a closer eye on new versions for tools you use often enough, specially languages like AutoIt which are likely to evolve constantly and leave you far behind if you don't adapt often.


This wonderful site allows debugging and testing regular expressions (many flavors available). An absolute must have in your bookmarks.
Another excellent RegExp tutorial. Don't forget downloading your copy of up-to-date pcretest.exe and pcregrep.exe here
RegExp tutorial: enough to get started
PCRE v8.33 regexp documentation latest available release and currently implemented in AutoIt beta.

SQLitespeed is another feature-rich premier SQLite manager (includes import/export). Well worth a try.
SQLite Expert (freeware Personal Edition or payware Pro version) is a very useful SQLite database manager.
An excellent eBook covering almost every aspect of SQLite3: a must-read for anyone doing serious work.
SQL tutorial (covers "generic" SQL, but most of it applies to SQLite as well)
A work-in-progress SQLite3 tutorial. Don't miss other LxyzTHW pages!
SQLite official website with full documentation (may be newer than the SQLite library that comes standard with AutoIt)

Share this post


Link to post
Share on other sites

Possibly worth adding that these window-property constants are just integers, and you can specify the number directly, or put the original library into the script folder so it takes precedence.

There are of course other changes, but if this is your main issue it should be easy enough to make a temporary fix this way.

Until recently I was still compiling one project with 3.1.1 because I hadn't the time or inclination to find out why it wouldn't compile with 3.3x. When It got to the stage where I needed it to make DLL calls, I just made it launch a second executable, compiled with 3.3.x

Sometimes, if it works... :mellow:

Share this post


Link to post
Share on other sites

Thanx bros! u guys use difficult words!! i needed a dictionary to translate  :mellow::PPosted Image  !! heheh

So the only way is to rewrite the scripts to be able to work with the new version :party:! mmm,, i was creating a "Lan Messenger" with old AutoIt, it took me alot of time, so i have to uninstall the new version and re-install the old one untill i finnish creating the Messenger, then i get the newer.. :party: it's easier to me than rewriting..  :party:, tha's if there is no "Converter"..

Thanx bros..

Share this post


Link to post
Share on other sites

@TinyHacker

The first place to start is by reading this topic which explains the major changes brought in by 3.2.12 - perhaps most importantly the need for many more include files to be specified.

What Melba23 means is all the "$ES_AUTOVSCROLL + $WS_VSCROLL + $ES_MULTILINE + $WS_EX_TOOLWINDOW" constants used to be in just a couple of includes, like GuiConstants.au3 and WindowsConstants.au3. But now, for instance, to get $ES_AUTOVSCROLL, or other $ES_xxxx constants you need to include EditConstants.au3.

Share this post


Link to post
Share on other sites

For finding the correct includes, you can try Organize Includes in my sig.


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

You don't need rewrite your scripts from scratch.

In most cases there must be only fixed list of include files at start of scripts.

There are utils for this purpose on the forum, see this topic

How to convert GUI scripts to v3.2.12.0

If you still will have problems with upgrading of your script

you may post your code here and I'm sure somebody will help you in such concrete script.

EDIT:

For language barier you can use great online tool

Google translator:

http://translate.google.com/

Edited by Zedna

Share this post


Link to post
Share on other sites

I think the best/most simple solution is this one by Autoit3Wrapper

#AutoIt3Wrapper_Add_Constants=y

See this for details

http://www.autoitscript.com/forum/index.php?showtopic=70902&view=findpost&p=529773

You must have full Scite4Autoit3 installed for this.

http://www.autoitscript.com/autoit3/downloads.shtml

http://www.autoitscript.com/autoit3/scite/downloads.shtml

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0