Jump to content
Sign in to follow this  

Same source code not work with new AutoIt

Recommended Posts



I have .exe compiled with, then I re-compiled it with and .exe stop at this point of code:

If WinWaitActive("Windowstitle","text text text text",3) = 1 Then

and without touching anything in code build work and can't send the 'keypress' text

Share this post

Link to post
Share on other sites


From the Changelog:

18th December, 2009 - v3.3.2.0

Added #764: Return Pid on ProcessWait() and handle on WinWait(), WinWaitActive, WinActivate(), WinActive(), WinMove() when successful.

So you need to look for a non-zero return rather than 1:

If WinWaitActive("Windowstitle","text text text text",3) <> 0 Then

should work for you. ;)


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:


ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area


Share this post

Link to post
Share on other sites

See the help file for winwaitactive function

Return Value

Success: Returns handle to the requested window.

Failure: Returns 0 if timeout occurred.

So your condition is bad.

Try :

If WinExists ("Windowstitle","text text text text") 
   WinActivate("Windowstitle","text text text text") 
   WinWaitActive("Windowstitle","text text text text",3) 

AutoIt X86 - SciTE 3.6.0WIN 8.1 X64 - Other Example Scripts

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.