Jump to content
Sign in to follow this  
kristsp

AutoItX on HTA and WIndows 7 64 bit

Recommended Posts

kristsp

I have problems with AutoItX3.Control on Windows 7 64 bit. I can create and use it in Windows Shell scripts (Wscript), but not in HTA or html javascript. It just says glorious "Automation server can't create object". Problem seems not to be related with security settings, as I can create and use Scripting.FileSystemObject in same hta file.

Same scripts work fine on good old Windows XP, but not on Windows 7 what happens to be target machine. My goal is to create hta application using, amongst other things, AutoItX control. I do not have Windows 7 32 bit here to test. Any help were to look for problems would be appreciated. Thanks!

Share this post


Link to post
Share on other sites
kristsp

Have you tried to register it as admin? I don't have Windows7 64bit, but 32 and it works (with HTA's).

All package was installed as admin user, so I guess that yes, dll files were silently registered during setup.

But according to your hint I tried to manually reregister dll files using regsvr32 and it is working now! Thanks for pointing me in right direction! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×