Sign in to follow this  
Followers 0
DannyDomb

Weird Problem...

7 posts in this topic

Hello,

I'm using Autoit for various purpose since a long time, and finally decided to register on the forum... simply because I have a problem with a very, but very simple script.

Comments are in french sry :)

#cs ----------------------------------------------------------------------------

 AutoIt Version: 3.3.6.1
 Author:         Danny Dombrowski

 Script Function:
    Installation Automatique de FaxTalk FaxPro 8

#ce ----------------------------------------------------------------------------
Run("cmd.exe")

; On attend que le process désiré soit actif
$isFail = ProcessWait("cmd.exe", 120)

If ($isFail == 0) Then
    MsgBox(0, "Erreur", "Process cmd.exe n'existe pas")
    Exit
EndIf

Sleep(2000)
WinActivate("[CLASS:ConsoleWindowClass]")
Send('msiexec /i "FaxTalk FaxCenter Pro 8.msi" TRANSFORMS=FaxCenterPro80.mst /passive{ENTER}')

; On attend que le process désiré soit actif
$isFail = ProcessWait("FTmdmset.exe", 120)

If ($isFail == 0) Then
    MsgBox(0, "Erreur", "Process FTmdmset.exe n'existe pas")
    Exit
EndIf

; On attend que notre fenêtre désiré apparaisse
Sleep(5000)

; On met la fenêtre désiré comme fenêtre active
WinActivate("Modem Selection")

Send("{TAB}")
Send("{TAB}")
Send("{DOWN}")
Send("{ENTER}")
Send("{TAB}")
Send("{TAB}")
Send("{TAB}")
Send("{ENTER}")

Everything is fine until it need to send Tabs or anything on the windows, I even tried to click in the windows and it doesn't work, also tried using ccontrols still the same result.

I can "WinActivate" the windows I launch with msiexec but, interacting with it is impossible.

Does anyone have any idea why? Was I clear enough for you to understand me ;) ?

Thank you guys.

Share this post


Link to post
Share on other sites



When you activate the window, where is the carrot? It may not be in the field you want to send the string to. If anything, try using controlsend. You should have better luck with that and as a bonus the window doesn't need to be active to do it.

Share this post


Link to post
Share on other sites

I dont want to input text, I simply want to naviguate into a programs to do next next... I can't use alt+u because of how the installer was made.

and as I said before, controls doesnt work either. I can detect if a control is enabled but I can't change his value.

Share this post


Link to post
Share on other sites

Like you said, I tried using control, but didn't post my code, so their is it the control part :

If ControlCommand("Modem Selection", "", "ComboBox1", "IsEnabled") == 1 Then
    #RequireAdmin
    ControlCommand("Modem Selection", "", "ComboBox1", "SetCurrentSelection", 1)
Else
    MsgBox(0, "Erreur", "CAN NOT FIND THE COMBOBOX")
EndIf

I always find it, but the ControlCommand doesnt work -.-

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

what about controlclick?

Doesn't work either, autoit recoderder or mouseclick doesnt even work.

Recorder doesnt record in the textbox any click in the windows.

Edited by DannyDomb

Share this post


Link to post
Share on other sites

Well, I think it is my antimalware who is blocking autoit from interacting in windows, is this possible?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0