Sign in to follow this  
Followers 0
AvN

code review_help

10 posts in this topic

Hi, I have some code here (part of a program) that worked well with windows xp. Now I am using windows 7, I am not sure why this is not working as expected. could some one a look and help me? Does it have to do with 64bit, 32 bit system? what to fix here and how?

Thank you.

Share this post


Link to post
Share on other sites



Hi, AvN. Perhaps you could post your code :)


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Hi, AvN. Are you receiving a specific error when you run this script on Win7? The more detail you can provide us the more quickly we can assist.


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

What isn't working on this script? You never said what the problem with it was.

BTW, this code:

$location = dircreate("C:DocumentsAvul")

Are you aware of what the value of $location will be if it creates the directory? Because you use it later in your script here:

RegWrite ( "HKEY_LOCAL_MACHINESOFTWAREL toolslog","Location", "REG_SZ", $location&"L-ToolsKllg")

DirCreate returns 1 if successful, and 0 if it fails, it does not return the directory name. When you used FileSelectFolder before, it would return the directory name, now it doesn't.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

think the error maybe "HKEY_LOCAL_MACHINE"

i use this to avoid error if i have 32/64 bits machines in a mixed enviroment..

If @OSArch = "X64" Then
Global $key7 = "HKLM64"
Global $key8 = "HKCU64"
Else
Global $key7 = "HKLM"
Global $key8 = "HKCU"
EndIf
$RemoteServer = RegRead($key7 & "SOFTWAREChargeChargeDeamon", "RemoteServer")

Share this post


Link to post
Share on other sites

There is no error message, but I noticed that " L-ToolsKllg" folder is not beeing created.

and it is not copying the file => filecopy(@ScriptFullPath,$location&"L-ToolsKllg"&@scriptname,1)

Share this post


Link to post
Share on other sites

What isn't working on this script? You never said what the problem with it was.

BTW, this code:

$location = dircreate("C:DocumentsAvul")

Are you aware of what the value of $location will be if it creates the directory? Because you use it later in your script here:

RegWrite ( "HKEY_LOCAL_MACHINESOFTWAREL toolslog","Location", "REG_SZ", $location&"L-ToolsKllg")

DirCreate returns 1 if successful, and 0 if it fails, it does not return the directory name. When you used FileSelectFolder before, it would return the directory name, now it doesn't.

correct, strange he says that it works on XP ?

Share this post


Link to post
Share on other sites

There is no error message, but I noticed that " L-ToolsKllg" folder is not beeing created.

and it is not copying the file => filecopy(@ScriptFullPath,$location&"L-ToolsKllg"&@scriptname,1)

Share this post


Link to post
Share on other sites

There is no error message, but I noticed that " L-Tools\Kllg" folder is not beeing created.

and it is not copying the file => filecopy(@ScriptFullPath,$location&"\L-Tools\Kllg\"&@scriptname,1)

$location doesn't contain a valid path so the directory doesn't exist for the file to be copied into. Plus, you're trying to copy the current file to that location it may be locked because it's in use at the time you're trying to copy it. As I explained above, DirCreate does NOT return the path that you created, it only contains a 1 or a 0 depending upon whether it created the directory.

If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0