Sign in to follow this  
Followers 0
arkstudios

Multiple links with same name on page.

4 posts in this topic

Hey everyone, my new project has me stumped. I searched and found a few post with how to do this

aittle bit but it's hard for me to understand. What I've got it a random number of links, 1 to 20

on a page. If it's just 1 link, i've got it working but now I need to try and expand my code.

I need to click a link, do a task, then go back and click the second. My main problem is the amount

of pages is random, and I don't have a clue where to go from here :)

<div class="linkblock">
<a href="[url=""]results.php?r=Hejh9zWQM4[/url]">
</div>
<div class="linkblock">
<a href="[url=""]results.php?r=BfOAUPdn1c[/url]">
</div>

Share this post


Link to post
Share on other sites



Show some AutoIt code


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

_IENavigate ($oIE, "")
$URL = _IEPropertyGet($oIE, "locationurl")
$oForm = _IEFormGetObjByName ($oIE, "info")
Local $oOrder = _IEFormElementGetObjByName($oForm, "orderform")
_IEAction($oOrder, "focus")
Send($x)
Send($y)
_IEFormSubmit($oForm)
$URL2 = _IEPropertyGet($oIE, "locationurl")
If  $URL <> $URL2 Then

sleep(1000)
_IEImgClick ($oIE, "placeorder.png")
sleep(1000)

Works perfect unless I get more than 1 result, like you see in the OP

Share this post


Link to post
Share on other sites

I'm still working on this :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0