Jump to content
Sign in to follow this  
Champak

ControlSetText problem

Recommended Posts

Champak

Im using ControlSetText on top of an image in a loop. The problem is the text that is set is just stacking up instead of replacing the previous text. Is this how it is suppose to be? I dont want to use GUICtrlSetData because it causes flickering. This didn't happen on my XP machine and the autoit version I had at that time...in 2009 I believe.

Share this post


Link to post
Share on other sites
Aipion

Use $WS_EX_COMPOSITED Extended Styles to reduce the flickering and only set the text if it is different because updating it too often can cause flickering.

Share this post


Link to post
Share on other sites
Champak

That doesnt work for me because it messes with numerous images I have...mostly the gui image background and text on the image buttons.

Share this post


Link to post
Share on other sites
Realm

Hello Champak,

I would still recommend using GuiCtrlSetData(). The Flicker is from running the GuiCtrlSetData() inside a loop, so I would recommend adding a check for the data to change before using the GuiCtrlSetData() function instead of it consistently trying to set the same data over and over which causes the flicker.

Something Like:

If $text_data <> GuiControlRead($my_control) Then GuiCtrlSetData($my_control, $text_data)
This should not mess with any of your images, especially if it's being applied to a label control that overlays the image control. If there is a need to hide the text in it's entirety, use GuiCtrlSetState() to Hide or Show the control as needed.

Realm


My Contributions: Unix Timestamp: Calculate Unix time, or seconds since Epoch, accounting for your local timezone and daylight savings time. RegEdit Jumper: A Small & Simple interface based on Yashied's Reg Jumper Function, for searching Hives in your registry.  

Share this post


Link to post
Share on other sites
Champak

It is setting text as/when it should....it's not running/setting text unnecissarily.

Share this post


Link to post
Share on other sites
BrewManNH

Post an example script that shows the problem and we can try and see what's happening and maybe how to fix it. No code...no clue.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×