Jump to content
Sign in to follow this  
willichan

Intermittent Compile Problem

Recommended Posts

willichan

I doubt AutoIt is the problem, but this is frustrating me. I am hoping someone else has seen this and has some ideas.

Intermittently, when I use "Compile with options" to compile scripts, I get the following error:

Error: EndUpdateResource: Returncode = 0 - LastError:0:The operation completed successfully.

At that point, it doesn't matter whether I tell it to continue or to stop. The resulting exe will produce the following error on my machine as well as any other I test it on:

Unable to open the script file.

My scripts use the following wrapper directives:

#region ;**** Directives created by AutoIt3Wrapper_GUI ****
#AutoIt3Wrapper_Icon=FixDif.ico
#AutoIt3Wrapper_Outfile=FixDif.exe
#AutoIt3Wrapper_Compression=4
#AutoIt3Wrapper_UseX64=n
#AutoIt3Wrapper_Res_Description=Repair file Association for Dif files with Excel
#AutoIt3Wrapper_Res_Fileversion=0.0.0.5
#AutoIt3Wrapper_Res_Fileversion_AutoIncrement=y
#AutoIt3Wrapper_Res_Language=1033
#AutoIt3Wrapper_Res_requestedExecutionLevel=asInvoker
#AutoIt3Wrapper_AU3Check_Stop_OnWarning=y
#AutoIt3Wrapper_Run_Tidy=y
#AutoIt3Wrapper_Run_Obfuscator=y
#Obfuscator_Parameters=/striponly
#endregion ;**** Directives created by AutoIt3Wrapper_GUI ****

I am running on a 64bit Win7 Enterprise N SP1 machine on a corproate domain.

AutoIt Version 3.3.8.1

SciTe Version 2.28

AutoIt Wrapper Version 2.1.0.8

I have full admin rights.

4Gig RAM

AV is Kaspersky Endpoint Security 8 (although turning AV off does not seem to fix the problem)

At this point, I just recompile 5-6 times until it works without errors, then test the resulting exe.

Any thoughts?

Edited by willichan

Share this post


Link to post
Share on other sites
BrewManNH

Do you have Windows Explorer open to the folder where the .exe is being created? If so try opening it to another folder first, then compiling. Sometimes having the folder open in Explorer causes the file to appear to be in use.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
willichan

Do you have Windows Explorer open to the folder where the .exe is being created?

That helped somewhat. It seems to have gone from 4 out of 5 errors down to 1 out of 5. I've got a good idea where to look now.

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×