Sign in to follow this  
Followers 0
ICANSEEYOU7687

Failure to load excel page

3 posts in this topic

#1 ·  Posted (edited)

Im really frustrated and confused. I have two almost identical excel spreadsheets I am trying to load into autoit I am using...

Global $oXLC_Excel = _ExcelBookOpen("C:path375.xls")
Local $aArray = _ExcelReadSheetToArray($oXLC_Excel)

My first excel file it loads fine, but the next one it cant load it into an array and i have NO idea why. The have different data in them, but are structurally identical.

And if someone could refresh me on how to use the @error...its been a while and google returned nothing helpful.

I just dont understand why its not even loading. It definitely finds the file fine, and it even opens the excel document correctly.

Any help would be greatly appreciated.

Thanks

*EDIT*

if I can just do

If @error Then MsgBox(0, "Failure", @error)

Then this is returning a "1", which is saying object does not exist. When it does clearly find and open the excel sheet.

Edited by ICANSEEYOU7687

Share this post


Link to post
Share on other sites



Here's how to check if there's an error.

Global $oXLC_Excel = _ExcelBookOpen("C:path375.xls")
If @error Then
     MsgBox(64, "Error", "Error opening file: " & @error)
EndIf
Local $aArray = _ExcelReadSheetToArray($oXLC_Excel)
If @error Then
     MsgBox(64, "Error", "Error reading sheet to array: " & @error)
EndIf

If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Thanks! I have been fiddling and its not a file thing like I thought.

Its a termination thing. My loop is not terminating correctly like it was in the first excel file. I do not know why but I should be able to work with this a little better

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0