Jump to content
Sign in to follow this  
jaja714

Why doesn't GUICtrlSetImage work?

Recommended Posts

jaja714

Why doesn't GUICtrlSetImage work?

#include <GUIConstantsEx.au3>
#include <ButtonConstants.au3>

$image = 'C:\Windows\winsxs\x86_setup-uxwizard-clientimages_31bf3856ad364e35_6.1.7600.16385_none_48ada01d8ff36e68\background.bmp'
$gui = GUICreate('test', 200, 200,-1,-1)
$button = GUICtrlCreateButton('test', 200, 0, 200,200, $BS_BITMAP)
GUICtrlSetImage($button, $image)

GUISetState(@SW_SHOW,$gui)

While 1
$msg = GUIGetMsg()
If $msg = $GUI_EVENT_CLOSE Then
SetError(1)
Exit
EndIf
WEnd

Share this post


Link to post
Share on other sites
bogQ

cos your button is off the scale from gui

change its position to something normal


TCP server and client - Learning about TCP servers and clients connection
Au3 oIrrlicht - Irrlicht project
Au3impact - Another 3D DLL game engine for autoit. (3impact 3Drad related)



460px-Thief-4-temp-banner.jpg
There are those that believe that the perfect heist lies in the preparation.
Some say that it’s all in the timing, seizing the right opportunity. Others even say it’s the ability to leave no trace behind, be a ghost.

 

Share this post


Link to post
Share on other sites
caleb41610

The question should have been, "Why doesn't my button show up?" because it looks to me like it starts at the same spot the GUI ends.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×