Sign in to follow this  
Followers 0
Hulkhogan

Help with AdlibRegister / AdlibUnregister

3 posts in this topic

Hi

I got a question about "AdlibRegister" and "AdlibUnregister"

I made a little Backupscript, using robocopy.

It will backup 6 libraries

There are 6 _RunDOS Commands, processed one by one.

Example:

_RunDOS (robocopy blabla library1 blabla)
_RunDOS (robocopy blabla library2 blabla)
....

OK, so far...

Now the question: I'd like to Adlibregister a function, which should get the size of the destinationfolder every 10 seconds while the _RunDOS Commands are being processed.

I do it like this:

AdlibRegister("FUNCBLABLA", 10000)
_RunDOS (robocopy blabla library1 blabla)
_RunDOS (robocopy blabla library2 blabla)
....
AdlibUnregister("FUNCBLABLA")

Func FUNCBLABLA()
$size = DirgetSize("UNCblabla")
GUICtrlSetData($blablalabel, $size)
Endfunc

OK, now...the destinationfolder is on a server, the sourcefolder(s) are local (what else....)

Sometimes, it works, sometimes it processes only 2 of the 6 _RunDOS Commands and the the script stands still...

why doesn't it work all the 6 steps EVERYTIME?....is it because of AdlibRegister?

Thanks for your help

Share this post


Link to post
Share on other sites



Thanks scrullion for your advice.

It's solved now.

The problem was that the 10 secs. were too short.

The Destinationfolder is - as mentioned - on a server.

At the beginning, there is no problem with getting the size.

But as soon as the dest. folder gets above 5 gig, the size is not calculated in between 10 secs. =)

so it just aborted the operation.

in the mainoffices, that would be OK as I guess.

But ATM i am @ a Branchoffice in another country...with a 30 Meg Link to the servers.... :P

Problem solved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0