Sign in to follow this  
Followers 0
Ebola

Help with TCP

3 posts in this topic

#1 ·  Posted (edited)

Hello all! I am new to AutoIT, but know the basics. I was recently working on this script, which isn't working. It works locally, but never works when I have a friend try it. I have port forwarded, but it still doesn't work. What I am trying to do, is have a friend run the Server, I run the client, and send messages to his computer.

Server:

HotKeySet("{ESC}", "ExitNow")
TCPStartup()
$Listening = TCPListen(@IPAddress1, 404)

$Accept = TCPAccept($Listening)
$Recv = TCPRecv($Accept, 1000000)
listen()
Func listen()
Do
$Accept = TCPAccept($Listening)
Until $Accept <> -1
recieve()
EndFunc ;==>listen
Func recieve()
Do
$Recv = TCPRecv($Accept, 1000000)
Until $Recv <> ""

Do
$Recv2 = TCPRecv($Accept, 1000000)
Until $Recv2 <> ""

MsgBox(48, $Recv2, $Recv)
While 1

WEnd
EndFunc ;==>recieve

Func ExitNow()
TCPShutdown()
Exit
EndFunc ;==>ExitNow

Client

#include <ButtonConstants.au3>
#include <EditConstants.au3>
#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>
$Form1 = GUICreate("Client", 313, 100)
$Input12 = GUICtrlCreateInput("MsgBox Title Here", 32, 20, 121, 21)
$Input1 = GUICtrlCreateInput("Message Here", 32, 50, 121, 21)
$Button1 = GUICtrlCreateButton("Send Msg", 184, 20, 100, 50)

$flag = 0
GUISetState(@SW_SHOW, $Form1)
TCPStartup()

$Connect = TCPConnect("FriendsIPHere", 403)

If $Connect = -1 Then
MsgBox(0, "Error", "Could not connect!")
EndIf
While 1
$nMsg = GUIGetMsg()
Switch $nMsg
Case $GUI_EVENT_CLOSE
Exit
Case $Button1
sendit($Connect)

EndSwitch
WEnd

Func sendit($Connect)
TCPSend($Connect, GUICtrlRead($Input1))
TCPSend($Connect, GUICtrlRead($Input12))
EndFunc ;==>sendit
Edited by Ebola

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

BUMP.

Really, no one can help?

Edited by Ebola

Share this post


Link to post
Share on other sites

Your friend have port forwarding as well? Are you using the external IP address of his system, and not the LAN IP address?

Doesn't work doesn't really tell us anything as to what isn't working. If it's not doing what you want it to do, then you need to find out where it's failing, and then ask specific questions in regard to where that failure is. Just trying it and not having it connect isn't really trouble shooting it.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0