Sign in to follow this  
Followers 0
denysrom

Radio Play problem.!

4 posts in this topic

#1 ·  Posted (edited)

A nice day to all .. I came back with a problem I built this program and fail to radio when pressed PLAY

When I press the radio Pro FM radio playing but the problem is that it does not work give me a help ?

#include
#include
#include
#include
#include
#include
#RequireAdmin
#NoTrayIcon


$IE = _IECreateEmbedded ()

Global $html , $oWMP
Local $GUI_DISABLED


$Form1 = GUICreate("Browser v2.1 |c0DEX|", 1025, 830, 195, 118)
GUISetBkColor(0xFF0000)
$Label1 = GUICtrlCreateLabel("URL", 8, 8, 36, 25)
GUICtrlSetFont(-1, 11, 800, 0, "Palatino Linotype")
$Input1 = GUICtrlCreateInput("", 48, 8, 585, 24, BitOR($GUI_SS_DEFAULT_INPUT,$ES_CENTER), BitOR($WS_EX_CLIENTEDGE,$WS_EX_STATICEDGE))
GUICtrlSetFont(-1, 10, 800, 0, "MS Sans Serif")
$Button1 = GUICtrlCreateButton("Go", 640, 8, 91, 25, -1, $WS_EX_STATICEDGE)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$Button2 = GUICtrlCreateButton("Home", 736, 8, 91, 25, -1, $WS_EX_STATICEDGE)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$Button3 = GUICtrlCreateButton("ABOUT", 928, 8, 91, 25, -1, $WS_EX_STATICEDGE)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$Button4 = GUICtrlCreateButton("EXIT", 832, 8, 91, 25, -1, $WS_EX_STATICEDGE)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$Label2 = GUICtrlCreateLabel("Clock", 8, 800, 48, 24)
GUICtrlSetFont(-1, 12, 800, 0, "MS Sans Serif")
$Input2 = GUICtrlCreateInput("", 56, 800, 121, 21)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
GUICtrlSetState($Input2,$GUI_DISABLE)
$Radio = GUICtrlCreateGroup("Radio", 184, 776, 833, 49)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$PROFM = GUICtrlCreateRadio("PROFM", 192, 800, 113, 17)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$Slider1 = GUICtrlCreateSlider(856, 788, 150, 30)
$Label3 = GUICtrlCreateLabel("Volume:", 768, 800, 60, 20)
GUICtrlSetFont(-1, 10, 800, 0, "MS Sans Serif")
GUICtrlCreateGroup("", -90, -99, 1, 1)
$Radio1 = GUICtrlCreateRadio("MaximaFM", 360, 800, 113, 17)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$Radio2 = GUICtrlCreateRadio("KisFM", 544, 800, 81, 17)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$Radio3 = GUICtrlCreateRadio("RadioMilos", 640, 800, 113, 17)
GUICtrlSetFont(-1, 8, 800, 0, "MS Sans Serif")
$Url = GUICtrlCreateObj($IE, 8, 40, 1009, 737)
GUISetState(@SW_SHOW)


_IENavigate($IE,"http://www.google.ro")








While 1
$nMsg = GUIGetMsg()
GUICtrlSetData($Input2,@HOUR & ":" & @MIN & ":" & @SEC)
Switch $nMsg
Case $GUI_EVENT_CLOSE
Exit

Case $Button1
$html = GUICtrlRead($Input1)
_IENavigate($IE,$html)

Case $Button2
_IENavigate($IE,"http://www.google.es")

Case $Button3
MsgBox(4096, "info", "Created by C0dex ...Hellshare60@gmail.com", 10)

Case $Button4
Exit(-1)

Case $Slider1
$Slider1= SoundSetWaveVolume(10)

Case $Radio
$oWMP = ObjCreate("WMPlayer.ocx")
$oWMP.URL= "http://www.wdr.de/wdrlive/media/einslive.asx"
$oWMP.Controls.Play



EndSwitch
WEnd
Edited by denysrom

[font=courier new,courier,monospace][u]Y Love You AutoiT[/u][/font]

Share this post


Link to post
Share on other sites



Look at your variables and you'll see it:

$PROFM = GUICtrlCreateRadio("PROFM", 192, 800, 113, 17)
Case $Radio

Also #RequireAdmin are not needed for IE or WMP so you can remove that + you seem to have 2 extra includes that aren't used.

Share this post


Link to post
Share on other sites

What can I do to start my radio? :bye:


[font=courier new,courier,monospace][u]Y Love You AutoiT[/u][/font]

Share this post


Link to post
Share on other sites

Sorry for so many questions but I am new in AutoiT :(


[font=courier new,courier,monospace][u]Y Love You AutoiT[/u][/font]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0