Jump to content
Sign in to follow this  
MasonMill

new au3 file

Recommended Posts

MasonMill

Hello,

I downloaded autoit on my laptop after a clean windows install and installed autoit, but before i did i was looking at an au3 file and told windows to open it with text editor. After autoit installed, the icon still looks like a txt file, meaning it is a white icon not the purple one that an au3 normally looks like. When i right click to make a new au3 file the option isnt there. I uninstalled autoit and reinstalled it but the problem persists. Anyone know how to remedy the sitation? Im using windows 7 home premium x64.

Thanks!

Share this post


Link to post
Share on other sites
Jos

Run the attached script and cut&paste the result so we can see what your registry settings are.

It will advice you what to do to fix it.

Jos :)

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
MasonMill

******************************************************************************************************************************************

!* Found always open with Win7:Applications\AutoIt3.exe

!* Fixed by removing Registry key: "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.au3\Userchoice"

!* Registry key: "HKCR\.au3" - "Default" is currently set to au3_auto_file ==> This should be changed to "AutoIt3Script" (or "AutoIt3ScriptBeta")

* HKCR\.au3 ShellNew :Template.au3 File Exists.

******************************************************************************************************************************************

* Explorer shell options:

* HKCR\au3_auto_file\shell:

* => Default Action:

*

* ShellNew:Template.au3

******************************************************************************************************************************************

Share this post


Link to post
Share on other sites
MasonMill

I rarely use the registry editor. Where do i find this key?

Share this post


Link to post
Share on other sites
MasonMill

got an error when i tried it saying "Cannot edit Progid: Error writing the values new contents"

Share this post


Link to post
Share on other sites
Jos

Where did you get that error?

Un-installing AutoIt3 and then installing it again should also fix this issue as far as I know.


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
MasonMill

i already tried reinstalling. I right clicked and modified the files in userchoice and got the error on both of the files. There are 2 files in usefchoce. (default) and Progid. Both gave me therror.

Share this post


Link to post
Share on other sites
Jos

Just tried it myself by doing an "Open With" for an au3 file and selected to always open with notepad.

That did create the registry key:

"HKCUSoftwareMicrosoftWindowsCurrentVersionExplorerFileExts.au3Userchoice"

I then started REGEDIT.EXE and deleted the userchoice key which restored the normal behaviour.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
MasonMill

I went in and deleted userchoices then the au3 file went to the blank icon like it didnt know what to open it with. When i right clicked it to open it i chose autoit to open it with and after doing so the icon turned back into the notepad emblem, not the purple autoit one. When i right clicked to edit the au3 file it took me to notepad not the normal autoit edit where the code is colored.

Share this post


Link to post
Share on other sites
MasonMill

ps ... you do have Admin rights to your Computer right?

Yep!

Share this post


Link to post
Share on other sites
Jos

I went in and deleted userchoices then the au3 file went to the blank icon like it didnt know what to open it with. When i right clicked it to open it i chose autoit to open it with and after doing so the icon turned back into the notepad emblem, not the purple autoit one. When i right clicked to edit the au3 file it took me to notepad not the normal autoit edit where the code is colored.

You do not what to do the right click open with thing. Do what the script has adviced being:

removing Registry key: "HKCUSoftwareMicrosoftWindowsCurrentVersionExplorerFileExts.au3Userchoice"

Change Registry key: "HKCR.au3" - "Default" is currently set to au3_auto_file ==> This should be changed to "AutoIt3Script" (or "AutoIt3ScriptBeta")

This will fix the settings to what the installer sets them.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
MasonMill

I deleted everything in the au3 regedit file so all that showed is default. I then pasted the "AutoIt3Script" the icon on my desktop is still a notepad emblem. When i double click it or right click it it still does not know what to open it with.

Share this post


Link to post
Share on other sites
MasonMill

Run the script again and show me the output to check if all is correct now.

to run it i have to pick a program to run it with, which then creates the wrong userchoice in the regedit.

Share this post


Link to post
Share on other sites
Jos

Just start SciTE that comes with Autot3 and do a File/Open for the script... then F5 to run it.

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
MasonMill

******************************************************************************************************************************************

!* Registry key: "HKCR.au3" - "Default" is currently set to au3_auto_file ==> This should be changed to "AutoIt3Script" (or "AutoIt3ScriptBeta")

* HKCR.au3 ShellNew :Template.au3 File Exists.

******************************************************************************************************************************************

* Explorer shell options:

* HKCRau3_auto_fileshell:

* => Default Action:

*

* ShellNew:Template.au3

******************************************************************************************************************************************

thats the output but when i go look at the regedit, "AutoIt3Script" is the value for all the defaults.

Share this post


Link to post
Share on other sites
Jos

So it seems you haven't updated the Default for registry key: HKCR\.au3

It should look like:

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.