Sign in to follow this  
Followers 0
empach

code worked yesterday, but not today??

11 posts in this topic

Hi,

I have a strange issue that my code was working yesterday, but today it is not.

when i run it i get this error message in the bottom window.

>"C:Program Files (x86)AutoIt3SciTE..autoit3.exe" /ErrorStdOut "C:UsersPaulDesktopAutoItteat.au3"
C:Program Files (x86)AutoIt3IncludeIE.au3 (314) : ==> The requested action with this object has failed.:
$o_object.navigate($s_Url)
$o_object.navigate($s_Url)^ ERROR
>Exit code: 1    Time: 0.414
 
 
 
any ideas??? 

Share this post


Link to post
Share on other sites



Lots, but probably not the ones you're looking for. Post the script if you want to get help.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

i reckon it says the erro comes from the IE.au3 included code, do you want me to post this code or my code??

Share this post


Link to post
Share on other sites

Maybe there's a problem with the site $s_Url points to? Can you succsessfully get to that URL manually?


- Bruce /*somdcomputerguy */  If you change the way you look at things, the things you look at change.

Share this post


Link to post
Share on other sites

yeah, and i can click the button i make reference to. but just not in the script

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

post the code which you run when you get error so that we can replicate problem and see whats wrong.

Edited by bogQ

TCP server and client - Learning about TCP servers and clients connection
Au3 oIrrlicht - Irrlicht project
Au3impact - Another 3D DLL game engine for autoit. (3impact 3Drad related)



460px-Thief-4-temp-banner.jpg
There are those that believe that the perfect heist lies in the preparation.
Some say that it’s all in the timing, seizing the right opportunity. Others even say it’s the ability to leave no trace behind, be a ghost.

 

Share this post


Link to post
Share on other sites

there in which lies another issue. its a code to login to a works server with my user details and password so i dont really want to post my code.

i do get this error when i run the function code alone

>"C:Program Files (x86)AutoIt3SciTE..autoit3.exe" /ErrorStdOut "C:UsersPaulDesktopAutoItSignIn.au3"
--> IE.au3 V2.4-0 Warning from function _IEGetObjByName, $_IEStatus_NoMatch (Name: ctl00$PageBody$btnShow, Index: 0)
--> IE.au3 V2.4-0 Warning from function _IEFormElementGetObjByName, $_IEStatus_NoMatch
--> IE.au3 V2.4-0 Error from function _IEFormElementOptionSelect, $_IEStatus_InvalidDataType
--> IE.au3 V2.4-0 Error from function _IEAction, $_IEStatus_InvalidDataType
 
 
i have re checked the GetObjByName refence with the HTML of the page so i know thats correct so it leads me to believe there is another issue??

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

if object have ID try with _IEGetObjById instead of name, maybe there are 2 objects with similar name or maybe your mixing name with ID or you need to reattach page with _IEAttach on new page. eather way with no info about scipt and page we cant do alot to help in guessing.

post part of html that handle that object and part of au3 script that get and i presume click that object

Edited by bogQ

TCP server and client - Learning about TCP servers and clients connection
Au3 oIrrlicht - Irrlicht project
Au3impact - Another 3D DLL game engine for autoit. (3impact 3Drad related)



460px-Thief-4-temp-banner.jpg
There are those that believe that the perfect heist lies in the preparation.
Some say that it’s all in the timing, seizing the right opportunity. Others even say it’s the ability to leave no trace behind, be a ghost.

 

Share this post


Link to post
Share on other sites

html:

<input type="submit" name="ctl00$PageBody$btnShow" value="Show Payslip" onclick="javascript:WebForm_DoPostBackWithOptions(new WebForm_PostBackOptions(&quot;ctl00$PageBody$btnShow&quot;, &quot;&quot;, true, &quot;ValidationSummary1&quot;, &quot;&quot;, false, false))" id="ctl00_PageBody_btnShow" class="button">

script:

 
Local $oPaySlip = _IEGetObjByName($oIE, "ctl00$PageBody$btnShow")

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

i shure hope that your $oIE isnt Local in some func and that your trying to get it in other func, try with ID

$oPaySlip = _IEGetObjById($oIE, "ctl00_PageBody_btnShow")

and do make shure that page is loaded with adding _IELoadWait($oIE,1000) just so that you dont try to get objects if page have double redirect or something

if that dont work try to reattach page to see if it helps.

Edited by bogQ

TCP server and client - Learning about TCP servers and clients connection
Au3 oIrrlicht - Irrlicht project
Au3impact - Another 3D DLL game engine for autoit. (3impact 3Drad related)



460px-Thief-4-temp-banner.jpg
There are those that believe that the perfect heist lies in the preparation.
Some say that it’s all in the timing, seizing the right opportunity. Others even say it’s the ability to leave no trace behind, be a ghost.

 

Share this post


Link to post
Share on other sites

tried those suggestions and still cant get it working, all except the reattach one (cos dont know what you are referring to)

thanks anyway - i shall read the whole script again as i must have inadvertently caught the keyboard or something cos i had it all working and now its not.

power off and back on again first tho ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0