Sign in to follow this  
Followers 0
xpresso

IE iframe input content

6 posts in this topic

I have successfully to click the button,and after that I need to input contents in the iframe "editor_iframe_1".

But after many trials it still can't work.

Does anyone have any idea?

Thanks~~

#include <IE.au3>
Local $link 
Local $oIE 
$link = String("http://gobuykorean.cc/")
$oIE = _IECreate($link)
$HWND = _IEPropertyGet($oIE, "hwnd")
WinSetState($HWND,"",@SW_MAXIMIZE)
_IEAction($oIE, "visible")
_IELoadWait($oIE)

$oIE = _IELinkClickByText($oIE,"發表")
_IELoadWait($oIE)
_IEAction($oIE, "click")
<div id="xe-editor-container-1" class="input_area xpress_xeditor_editing_area_container" style="height: 300px;">
            <iframe id="editor_iframe_1" allowtransparency="true" frameborder="0" src="http://gobuykorean.cc/modules/editor/styles/default/editor.html" scrolling="yes" style="width: 100%; height: 300px; display: block;"></iframe><textarea id="xpress-editor-1" rows="8" cols="42" style="display: none; width: 100%;"></textarea><textarea rows="8" cols="42" class="input_syntax " style="display: none;"></textarea>
        </div>
<iframe id="editor_iframe_1" allowtransparency="true" frameborder="0" src="http://gobuykorean.cc/modules/editor/styles/default/editor.html" scrolling="yes" style="width: 100%; height: 300px; display: block;"></iframe>

Share this post


Link to post
Share on other sites



Your code doesn't show any interaction with the frame. Take a look at _IEFrameGetObjByName in the help file.

Share this post


Link to post
Share on other sites

I have used _IEFrameGetCollection and _IEForm...and _IEgetobj,but none of this can be used

Someone can help me~~

Share this post


Link to post
Share on other sites

I believe that you will receive additional help if you will post some code showing what you've tried that didn't work. You can't expect someone to write the whole thing for you.

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

#include <IE.au3>
Local $link 
Local $oIE 
$link = String("http://gobuykorean.cc/")
$oIE = _IECreate($link)
$HWND = _IEPropertyGet($oIE, "hwnd")
WinSetState($HWND,"",@SW_MAXIMIZE)
_IEAction($oIE, "visible")
_IELoadWait($oIE)
_IELinkClickByText($oIE,"發表")
_IELoadWait($oIE)
$obj = _IEGetObjByName($oIE,"editor_iframe_2")
_IEFormElementSetValue($obj,"This is a test")

The last line need to write text into frame,but i was wondering if the "_IEGetObgByName" really get the name.

Now the script can click the button and load website completely,and after that the script seems to be void.

Edited by xpresso

Share this post


Link to post
Share on other sites

Use _IEFrameGetObjByName instead of _IEGetObjByName.  It returns the frame (document container) instead of the frame tag.

Dale

 


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0