Sign in to follow this  
Followers 0

Terminal Service Profile function dont work in Windows 7

2 posts in this topic

#1 ·  Posted (edited)

This function to set Terminal Service information that i wrote a few years ago (with water's help), always worked in Windows XP, but no longer seems to work now that we changes over to Windows 7 machines. all other AD functions seem to work fine. could there be something missing in windows 7 like a .dll or something?

Func _AD_SetTSProfile($sAD_User)

 If Not _AD_ObjectExists($sAD_User) Then Return SetError(1, 0, 0)
 Local $ID = $sAD_User
 If StringMid($sAD_User, 3, 1) <> "=" Then $sAD_User = _AD_SamAccountNameToFQDN($sAD_User) ; sAMACccountName provided

 $oAD_User.TerminalServicesProfilePath = "Servertsprofiles" & $ID
 $oAD_User.TerminalServicesHomeDirectory = "Servertshome" & $ID
 $oAD_User.TerminalServicesHomeDrive = "Z:"
 $oAD_User.AllowLogon = True

 If @error <> 0 Then Return SetError(@error, 0, 0)
 Return 1

EndFunc   ;==>_AD_SetTSProfile


i ran this small script for the purpose of troubleshooting

#Include <AD.au3>
#Include <lauze.au3>
$sAD_User = "TestUser"

 $result = _AD_SetTSProfile($sAD_User)
 ConsoleWrite("   " & $result & "  - " &  @error & "  -  ")




>Running:( Files (x86)AutoIt3autoit3.exe "P:DocumentsAuto Ittestts_win7.au3"   
--> Press Ctrl+Alt+F5 to Restart or Ctrl+Break to Stop
   0  - -2147352570  -  +>14:02:37 AutoIt3.exe ended.rc:0
>Exit code: 0    Time: 0.820

Edited by paullauze

Share this post

Link to post
Share on other sites

i think the missing item my be the ADMINPACK


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • steveeye
      By steveeye
      hey, can anybody enlighten on lesser known Windows hacks or uses ?
    • afallenhope
      By afallenhope
      Hello all! 
      I am having a bit of trouble and was wondering if anyone may have a workaround for my issue. I made a script that would automatically install a piece of software each night on a Windows 7 Box. Now I have been instructed to do the same with a Windows 10 box since the application is now being tested on Windows 10. 
      The way I did the win7 installation was that I made a script and then made an executable that I call with a batch file along with the Installer. So the process is 
      AutoitMainFile calls batch file, batch file opens Installer, and the automatedinstaller.exe  The automatedinstlaller waits 10-20 seconds to make sure the Installer has been fully loaded.
      When I try to do the same both get loaded but the automatedinstallation.exe does not send commands to the installer. The code does work and nothing from the program we are wanting to install has changed as our Windows 7 runs every night no problem. 
      Do I need to make a new automatedinstall script for windows 10? 
      Any advice is appreciated 
    • ur
      By ur
      I have enabled admin sharing in the remote machine so that I can copy files to the remote machine use PSEXEC to execute our application remotely.
        Now, if the machine is poweredoff we need to poweriton. So I checked whether the remote machine, it is of both VirtualBox or VMWare one. For VirtualBox or VMware, I have found command line utities to poweron.   But to autologon by skipping the login screen.Can anyone suggest how to do the same.If it is a physical machine, then there is no need to poweron but autologon is required.   I am trying for windows machines.Win 7 at present.   For VirtualBox I checked below link with help og guestadditions but not working.   The below procedure will save the password in that machine and it will logon automatically.   But it will give access to everyne.But my opinion is he should access only if have credentias.I mean through any commandline from another machine he should trigger logon also by passing credentials.     Similarly this also   Please guide me how to proceed.
    • AJB
      By AJB
      I've been using autoit for about a year now and overall it's been great despite my limited understanding of all of its features. I have several scripts that run on virtual machines that have been running smoothly for several months without any issues. Recently, I had to create new virtual machines and migrate my scripts over and now I am getting errors that I can't seem to repeat, but seem to happen at least once a day with all of my executables that were flawless before.
      The error that I keep getting is:
      Autoit Error
      Line [this number varies per script] (File "[path to my executable]"); Error: variable must be of type object.
      I  never received this error before until I moved everything to the new VMs, and when I rerun my scripts after clearing the error everything seems to work and run fine until hours later or sometimes the next day. I am assuming that that the root cause may be in some kind of settings on the VM itself since it is happening nearly across the board, but I have no idea where to even look. These are running on Windows 7, which is what they were running on before I had any errors.
      The only consistent include used in these scripts is  IE.au3
      Has anyone run into a similar problem or can maybe point me in the right direction. I am at the point of pulling hair out trying to resolve this. I have even rewritten and re-compiled the scripts to see if somehow the executables got corrupted, but that didn't help.
      Thank you.
    • tbohon
      By tbohon
      Loaded from latest releases of both AutoIt and SciTE and attempted to test by creating a simple SQLite script.  When trying to run the script I get an 'Error Opening File' error on line 45 of AutoIt3Wrapper.au3 which consists of the following code:
      #include <WinAPIFiles.au3>  
      Unable to find this file anywhere on my hard drive and unable to find any patch or similar error on the forum.
      TIA ...   Tom