Jump to content
Sign in to follow this  
trupoed

Send key combonations like '^s' and '!l' doesn't work

Recommended Posts

trupoed

Hello!

I've got a problem width sending key combinations like '^s', '!l' etc. I wrote a simple script:
 

WinActivate("[CLASS:TnsMainWindow]")
;Send("!{l}")
Send("^s")
Exit

I've got 3 PCs: Win8, Win7 and Win7 notebook. The first two are ok. But the script doesn't work at Win7 notebook. If I write Send("^s"), it sends only "s". If I send Ctrl+s manually using keyboard - it works fine.
The same for "!l", "!f", "^a", "^v" etc. It happens only at win7 notebook. Win7 and Win8 PCs are OK.

I also tried something like "{CTRL down}s{CTRL up}" - it doesn't work too.

Can anyone help me?

Share this post


Link to post
Share on other sites
trupoed

The problem is solved. 
Just set default language English in windows language settings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.