Jump to content
Sign in to follow this  
Guest b.byers

File path error

Recommended Posts

Guest b.byers

Everytime I run this script from SMS I get a "File Path Error". If I remove the RunAsSet the script runs with no problem, but I need the elevated permissions since not all of my users have local admin rights to their machines.

RunAsSet("user", "domain", "password")
Opt("WinWaitDelay",100)
Opt("WinTitleMatchMode",4)
Opt("WinDetectHiddenText",1)
Opt("MouseCoordMode",0)
Run("\\server101\files$\ilinc\iLincStandardClient.exe","", @SW_MAXIMIZE)
WinWait("WinZip Self-Extractor","Would you like to in")
If Not WinActive("WinZip Self-Extractor","Would you like to in") Then WinActivate("WinZip Self-Extractor","Would you like to in")
WinWaitActive("WinZip Self-Extractor","Would you like to in")
Send("{ENTER}")
WinWait("Preparing iLinc","The iLinc Client is ")
If Not WinActive("Preparing iLinc","The iLinc Client is ") Then WinActivate("Preparing iLinc","The iLinc Client is ")
WinWaitActive("Preparing iLinc","The iLinc Client is ")
Send("{ENTER}")

Share this post


Link to post
Share on other sites
GaryFrost

carefull using local admin account, the account may not have access to the network/lan.

a simple test would be to do a runas cmd then see what you can access.

Edited by gafrost

SciTE for AutoItDirections for Submitting Standard UDFs

 

Don't argue with an idiot; people watching may not be able to tell the difference.

 

Share this post


Link to post
Share on other sites
Jos

It is very likely that the Path this script is ran from isn't available for the Credentials the Run() uses. Make sure you do a FileChangeDir() before the Run() or Specify the Workingdir in the Run command....


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Guest b.byers

Thanks.

Problem solved.

It was the fact that the working directory was not specified. Once I did that, then it works great through SMS.

Thanks once again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×