Jump to content
Sign in to follow this  
LsDmt

Auto login Script

Recommended Posts

LsDmt

Hello, Im new here,

I'm LsDmt.

Trying to learn AutoIT, just started a couple of days ago - total beginner, no previous coding experience - some understanding of logic though.

Firstly I got some really, really noob-ish questions.

1.

What's the difference, or is there any difference in doing caps vs. small letters in commands.

Example:

msgbox

Msgbox

MsgBox

MSGBOX

2.

I'm trying to make an autologin script for a social website and I'm using;

#include <IE.au3>

But the "_IE***" commands doesn't show up. Neither do they get "blue" when copy pasted into the script directly, they just look like black plain text.

3.

As I said I'm trying to make an auto login bot for a social website, and I've been looking at some youtube tutorials, like this one, for example.

Right now I'm only trying to get the script to open IE and then login. But my goal is to:

Open IELogin to: www.kamrat.seStay logged in for n timeLogout and wait for n timeRepeat (but skip step 1).

But when I try my script, IE opens and nothing more happens, then I get this message:

>"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "C:\Users\LsDmt\Desktop\Kamrat.au3"
--> IE.au3 V2.4-0 Warning from function _IEGetObjByName, $_IEStatus_NoMatch (Name: id, Index: 0)
--> IE.au3 V2.4-0 Warning from function _IEGetObjByName, $_IEStatus_NoMatch (Name: pass, Index: 0)
--> IE.au3 V2.4-0 Warning from function _IEGetObjByName, $_IEStatus_NoMatch (Name: Submit, Index: 0)
C:\Users\LsDmt\Desktop\Kamrat.au3 (17) : ==> Unknown function name.:
_IEFornElementSetValue ($username, "xxx")
^ ERROR
>Exit code: 1    Time: 2.941

Even though I've just checked www.kamrat.se, the site that I want to login to, with FireBug on Firefox, for the name of the account and password boxes and the login button. They seem to be "id", "pass" and "Submit".

I don't know if it's needed but here's a download to my script, otherwise you can just look at it here:

#include <IE.au3> 



Call ("signIn")




Func signIn ()
Global $oIE = _IECreate ("http://www.kamrat.com")

Local $username = _IEGetObjByName ($oIE, "id")
Local $password = _IEGetObjByName ($oIE, "pass")
Local $button = _IEGetObjByName ($oIE, "Submit")

_IEFornElementSetValue ($username, "xxx")
_IEFornElementSetValue ($password, "xxx")

_IEAction ($button, "click")




EndFunc

4.

Am I using the wrong version of AutoIT?

I'm currently using:

  • AutoIT v3
  • SciTE-Lite Version 2.28

Is this a good version, should I change?

Note: I've changed my account and password to xxx.

I appreciate ANY help I can get!

Thanks in advance,

LsDmt.

Edited by LsDmt

Share this post


Link to post
Share on other sites
Melba23

LsDmt,

Welcome to the AutoIt forum. :)

Answer 1: Other than in literal strings that you create and delimit with quotes, AutoIt is case-insensitive.

Answer 2: Do other functions (like MsgBox) become coloured when you type them into SciTE? If so, then it looks as if the #include is not working - see below.

Answer 3 & 4: From where did you download AutoIt? The current release version is 3.3.8.1 - you can check on this by running this code:

ConsoleWrite(@AutoItVersion & @CRLF)
However, given the problem you have with _IE* functions, even if it does say "3.3.8.1" in the lower SciTE pane I suggest you reinstall with the version you can get from here and see if that solves the problems.

Let us know how you get on. :)

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites
LsDmt

LsDmt,

Welcome to the AutoIt forum. :)

(...)

Let us know how you get on. :)

M23

 

 

Well thanks! :bye:

2. Yes other functions like MsgBox or Func gets coloured blue while $variables gets coloured brown/dark red and "values" white/gray.

However the #include is coloured pink, while the <IE.au3> is white/gray, like this;

#include <IE.au3>

 

3 & 4. I actually don't remember super clearly, what happened, when.

I think I downloaded someones self coded .exe auto loot bot for a game long time ago. I seem to remember that, that particular .exe actually used AutoIT, and that some version of AutoIT was included in the download. Then recently I re-downloaded the newest version from the AutoIT website and installed (and updated). Something must have went wrong there I think, be cause I got version 3.3.8.1 when I ran the command you provided;

>"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "C:\Users\LsDmt\Desktop\z.au3"
3.3.8.1
>Exit code: 0    Time: 0.213

So yeah, I should probably just uninstall both that old autoloot bot and AutoIT, then reinstall the newest version again.

 

I'll get back with my results tomorrow though... Good night! -_- zzZ

Edited by LsDmt

Share this post


Link to post
Share on other sites
BrewManNH

Note: "_IEFornElementSetValue" does not equal "_IEFormElementSetValue"


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
Bert

...So yeah, I should probably just uninstall both that old autoloot bot and AutoIT, then reinstall the newest version again....

You may want to read the forum rules. (look in the lower right of this screen for the link) We do not condone game bots here. The mods get quite "clickey" (© Jos) when they find a thread on that subject.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×