Sign in to follow this  
Followers 0
Graeme

Does GUICtrlRead work with arrays

3 posts in this topic

Dear all,

I created some GUICtrlCreateInputs with this script

$MappingNo =1

$MappingsIndexStop = $MappingCount-1
If $MappingsIndexStop > 6*$MappingScreen Then $MappingsIndexStop = 6 * $MappingScreen; to show only 6 at a time
$MappingsIndexStart = $MappingsIndexStop-5
If $MappingsIndexStart<1 Then $MappingsIndexStart=1

For $I = $MappingsIndexStart to $MappingsIndexStop

If StringLeft($SetMappings [$I],getposition($SetMappings [$I],":")-1) = "-1" Then;-1 is for the local mappings
   GUICtrlCreateLabel($SetMappingText&"_"& $I &"="&$MappingNo,12,35+$MappingNo*20,100)
   $MappingsInput [$MappingNo] = GUICtrlCreateInput(stringright($SetMappings [$I],stringlen($SetMappings [$I])- _ 
   getposition($SetMappings [$I],":")),winSpace($SetMappingText)+20,35+$MappingNo*20,$WindowSize - winSpace($SetMappingText)-20)
   $MappingNo = $MappingNo +1
EndIf

and then I tried reading them to save any changes .. It just doesn't seem to work..

$MappingNo=1

         For $M= $MappingsIndexStart to $MappingsIndexStop
            $SetMappings [$M] = "-1:" & GUICtrlRead($MappingsInput [$MappingNo]);to  restore $setmappings for changes
            $MappingNo=$MappingNo+1
         Next

Can anyone see a problem? It does the first one and then gives a blank. Doesn't seem to matter whether I've changed the Input or not.

Any help gratefully received. Thanks

Graeme

Share this post


Link to post
Share on other sites



Could you post a working script that demonstrates the problem? Right now, there's so much missing that it's hard to follow.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Well I tried to create a working script and ... it works. That shows me where the error isn't - GUICtrlRead works with arrays - so now I'll carry on looking elsewhere. Thanks for the good steer BrewMan!

Blessings

Graeme

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0