Sign in to follow this  
Followers 0
SYY999

problem with CompInfo.au3

6 posts in this topic

Hi, i wrote this little program

#include <CompInfo.au3>

#Region ;~~ Computer Infomartion
    Local $CompInf
    Local $CPURam
    Local $CPUInfo = ''
    $CPUInfo &= '===>CPU Information' & @CRLF
    _ComputerGetOSs($CompInf)
    $CompInf = StringSplit($CompInf[1][0], '|')
    $CPUInfo &= 'OS: ' & @TAB & @TAB & @TAB & $CompInf[1] & @CRLF

    _ComputerGetSystem($CompInf)
    $CPUInfo &= 'System: ' & @TAB & @TAB & $CompInf[1][46] & @CRLF

    _ComputerGetProcessors($CompInf)
    $CPUInfo &= 'CPU: ' & @TAB & @TAB & @TAB & $CompInf[1][0] & @CRLF

    _ComputerGetMemory($CompInf)
    For $i = 1 To $CompInf[0][0]
        $CPURam += $CompInf[$i][2]
    Next
    $CPUInfo &= 'Ram: ' & @TAB & @TAB & @TAB & Round(Number($CPURam/1024^2)) & ' MB' & @CRLF

    _ComputerGetVideoCards($CompInf)
    For $i = 1 To $CompInf[0][0]
        $CPUInfo &= 'VGA' & $i & ': ' & @TAB & @TAB & @TAB & $CompInf[$i][0] & @CRLF
    Next

    _ComputerGetMonitors($CompInf)
    For $i = 1 To $CompInf[0][0]
        $CPUInfo &= 'Monitor' & $i & ': ' & @TAB & @TAB & $CompInf[$i][21] & '*' & $CompInf[$i][20] & @CRLF
    Next
#EndRegion

MsgBox(0, '', $CPUInfo)

all it does is fetch some information about my computer. It worked well before i formatted my PC. Now when i run the script the icon just appears in the tray and after 5s it disappears, without any messageboxes.. 

if i remove all functions except _ComputerGetOSs and _ComputerGetMemory, the program will work. Any idea why the others do not work?

Share this post


Link to post
Share on other sites



Have you tried running the script in Scite and reviewing the output window for any errors?

Also, what version of Autoit are you using?

Share this post


Link to post
Share on other sites

i dont really understand the console output >.<

>"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "C:\Users\J\Desktop\compinfo test#.au3" /UserParams    
+>15:52:42 Starting AutoIt3Wrapper v.2.1.4.0 SciTE v.3.3.7.0 ;  Keyboard:00000407  OS:WIN_7/Service Pack 1  CPU:X64 OS:X64    Environment(Language:0409  Keyboard:00000407  OS:WIN_7/Service Pack 1  CPU:X64 OS:X64)
>Running AU3Check (3.3.10.2)  from:C:\Program Files (x86)\AutoIt3
+>15:52:43 AU3Check ended.rc:0
>Running:(3.3.10.2):C:\Program Files (x86)\AutoIt3\autoit3.exe "C:\Users\J\Desktop\compinfo test#.au3"    
--> Press Ctrl+Alt+F5 to Restart or Ctrl+Break to Stop
!>15:52:53 AutoIt3.exe ended.rc:-1073741819
>Exit code: -1073741819    Time: 10.940

i just downloaded autoit. So its version is v3.3.10.2

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

AutoIt3 is having a 0xc0000005 hardcrash so you need to check the Included UDF's.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

This seems to be related to a bug in v3.3.10.2, please see trac ticket #2613.  For a workaround, please look at >this thread.  It will require editing some functions in the UDF.  

 

Adam

Edited by AdamUL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0