Jump to content
Sign in to follow this  
someone

XML Can't Read Attributes

Recommended Posts

someone

Hey everyone,

This is driving me crazy I'm hoping someone can help me out.  I am trying to read from an XML that is created by a MS program (so I can't change anything about the file structure) but everytime I try to read attributes (or anything else) while the xmlns="" exists in the XML I can't get anything to work.

Reproducer;

Global $strFile
Global $DOMVERSION = -1
Global $objDoc

$sPath_PackageXML = ".\UserDeploymentConfiguration.xml"

$sret = _XMLFileOpen($sPath_PackageXML);, 'xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"')
MsgBox(0, $sret, @error & " : " & @extended)
;the open ALWAYS works, have both used the namespace argument and not used

$temp_attrib = _XMLGetAttrib("/DeploymentConfiguration", "DisplayName")
MsgBox(0, "debug test : " & @error & " : " & @extended, $temp_attrib)
;this should work

; #FUNCTION# ===================================================================
; Name ..........: _XMLGetAttrib
; Description ...: Get XML Field based on XPath input from root node.
; Syntax.........:  _XMLGetAttrib($strXPath, $strAttrib[, $strQuery = ""])
; Parameters ....: $strXPath      - XML tree path from root node (root/child/child..)
;                  $strAttrib     - The attribute node to read.
;                  $strQuery      - The query string in xml format
; Return values .: Success        - The attribute value.
;                  Failure        - -1 and sets @Error to:
;                  |0 - No error
;                  |1 - Attribute not found.
;                  |2 - No object
; Author ........: Stephen Podhajecki <gehossafats@netmdc.com>
; Modified ......:
; Remarks .......:
; Related .......:
; Link ..........;
; Example .......; [yes/no]
; ==============================================================================
Func _XMLGetAttrib($strXPath, $strAttrib, $strQuery = "")
    If Not IsObj($objDoc) Then
        MsgBox(0, "Error", "No object passed to function _XMLGetAttrib")
        ;_XMLError("No object passed to function _XMLGetAttrib")
        Return SetError(2, 0, -1)
    EndIf
    ;Local $objNodeList, $arrResponse[1], $i, $xmlerr, $objAttr
    Local $objNodeList, $arrResponse, $i, $xmlerr, $objAttr
    $objNodeList = $objDoc.documentElement.selectNodes($strXPath & $strQuery)
    ;_DebugWrite("Get Attrib length= " & $objNodeList.length)
    If $objNodeList.length > 0 Then
        For $i = 0 To $objNodeList.length - 1
            $objAttr = $objNodeList.item($i).getAttribute($strAttrib)
            $arrResponse = $objAttr
            ;_DebugWrite("RET>>" & $objAttr)
        Next
        Return $arrResponse
    EndIf
    $xmlerr = "\nNo qualified items found"
    MsgBox(0, "Error", "Attribute " & $strAttrib & " not found for: " & $strXPath & $xmlerr)
    ;_XMLError("Attribute " & $strAttrib & " not found for: " & $strXPath & $xmlerr)
    Return SetError(1, 0, -1)
EndFunc   ;==>_XMLGetAttrib

; #FUNCTION# ===================================================================
; Name ..........: _XMLFileOpen
; Description ...: Creates an instance of an XML file.
; Syntax.........:  _XMLFileOpen($strXMLFile[, $strNameSpc = ""[, $iVer = -1[, $fValOnParse = True]]])
; Parameters ....: $strXMLFile    - the XML file to open
;                  $strNameSpc    - the namespace to specifiy if the file uses one.
;                  $iVer          - specifically try to use the version supplied here.
;                  $fValOnParse   - validate the document as it is being parsed
; Return values .: Success        - 1
;                  Failure        - -1 and set @error to:
;                  |0 - No error
;                  |1 - Parse error, @Extended = MSXML reason
;                  |2 - No object
; Author ........: Stephen Podhajecki <gehossafats@netmdc.com>
; Modified ......:
; Remarks .......:
; Related .......:
; Link ..........;
; Example .......; [yes/no]
; ==============================================================================
Func _XMLFileOpen($strXMLFile, $strNameSpc = "", $iVer = -1, $fValOnParse = True)
    ;==== pick your poison
    If $iVer <> -1 Then
        If $iVer > -1 And $iVer < 7 Then
            $objDoc = ObjCreate("Msxml2.DOMDocument." & $iVer & ".0")
            If IsObj($objDoc) Then
                $DOMVERSION = $iVer
            EndIf
        Else
            MsgBox(266288, "Error:", "Failed to create object with MSXML version " & $iVer)
            SetError(1)
            Return 0
        EndIf
    Else
        For $x = 8 To 0 Step -1
            If FileExists(@SystemDir & "\msxml" & $x & ".dll") Then
                $objDoc = ObjCreate("Msxml2.DOMDocument." & $x & ".0")
                If IsObj($objDoc) Then
                    $DOMVERSION = $x
                    ExitLoop
                EndIf
            EndIf
        Next
    EndIf
    If Not IsObj($objDoc) Then
        MsgBox(0, "Error", "Error: MSXML not found. This object is required to use this program.")
        ;_XMLError("Error: MSXML not found. This object is required to use this program.")
        SetError(2)
        Return -1
    EndIf
    ;Thanks Lukasz Suleja
    $oXMLMyError = ObjEvent("AutoIt.Error")
    If $oXMLMyError = "" Then
        $oXMLMyError = ObjEvent("AutoIt.Error", "_XMLCOMEerr") ; ; Initialize SvenP 's error handler
    EndIf
    $strFile = $strXMLFile
    $objDoc.async = False
    $objDoc.preserveWhiteSpace = True
    $objDoc.validateOnParse = $fValOnParse
    If $DOMVERSION > 4 Then $objDoc.setProperty("ProhibitDTD", False)
    $objDoc.Load($strFile)
    $objDoc.setProperty("SelectionLanguage", "XPath")
    $objDoc.setProperty("SelectionNamespaces", $strNameSpc)
    If $objDoc.parseError.errorCode > 0 Then ConsoleWrite($objDoc.parseError.reason & @LF)
    If $objDoc.parseError.errorCode <> 0 Then
        MsgBox(0, "Error", "Error opening specified file: " & $strXMLFile & @CRLF & $objDoc.parseError.reason)
        ;_XMLError("Error opening specified file: " & $strXMLFile & @CRLF & $objDoc.parseError.reason)
        ;Tom Hohmann 2008/02/29
        SetError(1, $objDoc.parseError.errorCode, -1)
        $objDoc = 0
        Return -1
    EndIf
    ;Tom Hohmann 2008/02/29
    Return 1
EndFunc   ;==>_XMLFileOpen

I included the functions from the UDF for easier reproduction -- UDF found here ()

This XML doesn't work;

<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>
 

This XML does;

<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname" ></DeploymentConfiguration>
 

I'm not against using something else other then the XML DOM, so any suggestions welcome.  I'm at the point I might go back to fileread operations.

Thanks in advance.

UserDeploymentConfiguration.xml


While ProcessExists('Andrews bad day.exe')
	BlockInput(1)
	SoundPlay('Music.wav')
	SoundSetWaveVolume('Louder')
WEnd

Share this post


Link to post
Share on other sites
jdelaney

Both work for me:

$oXML = ObjCreate("Microsoft.XMLDOM")

$xml = '<?xml version="1.0"?><DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname1" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>'
$oXML.loadxml($xml)
ConsoleWrite($oXML.xml & @CRLF)
For $oConfig in $oXML.selectNodes("//DeploymentConfiguration")
    $sDisplayName = $oConfig.getAttribute('DisplayName')
    ConsoleWrite($sDisplayName & @CRLF)
Next

$xml = '<?xml version="1.0"?><DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname2" ></DeploymentConfiguration>'
$oXML.loadxml($xml)
ConsoleWrite($oXML.xml & @CRLF)
For $oConfig in $oXML.selectNodes("//DeploymentConfiguration")
    $sDisplayName = $oConfig.getAttribute('DisplayName')
    ConsoleWrite($sDisplayName & @CRLF)
Next

output:

<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname1" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>

testDisplayname1
<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname2"></DeploymentConfiguration>

testDisplayname2


IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites
someone

Hey jdelaney,

Thanks a lot!  I tried using microsoft.xmldom (actually from one of your posts) but turns out I missed that you have to pass the XML as a string... I kept feeding it a filename...Doh!  >_<  .  Is the Microsoft.XMLDOM better/worse, newer or older compared to Msxml2.DOMDocument I am using from eltorro's UDF?

Any ideas on why it only works with Microsoft.XMLDOM?

 

Thanks so much for the help, really appreciate it.

Edited by someone

While ProcessExists('Andrews bad day.exe')
	BlockInput(1)
	SoundPlay('Music.wav')
	SoundSetWaveVolume('Louder')
WEnd

Share this post


Link to post
Share on other sites
jdelaney

You can load an XML file, just pass in the file as the param, and change .xmlload to .xml...or maybe just .load...I forget (your own quick google search if interested)

For my samples, I don't do that, so it's a stand alone script

Edited by jdelaney

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites
someone

Yeah understandable... thanks again.


While ProcessExists('Andrews bad day.exe')
	BlockInput(1)
	SoundPlay('Music.wav')
	SoundSetWaveVolume('Louder')
WEnd

Share this post


Link to post
Share on other sites
jdelaney

The MSXML2 version 3.0 works, none of the others do though:

$oXML = ObjCreate("Microsoft.XMLDOM")

$xml = '<?xml version="1.0"?><DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname1" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>'
$oXML.loadxml($xml)
ConsoleWrite($oXML.xml)
For $oConfig in $oXML.selectNodes("//DeploymentConfiguration")
    $sDisplayName = $oConfig.getAttribute('DisplayName')
    ConsoleWrite($sDisplayName & @CRLF & @CRLF & @CRLF)
Next

$xml = '<?xml version="1.0"?><DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname2" ></DeploymentConfiguration>'
$oXML.loadxml($xml)
ConsoleWrite($oXML.xml & @CRLF)
For $oConfig in $oXML.selectNodes("//DeploymentConfiguration")
    $sDisplayName = $oConfig.getAttribute('DisplayName')
    ConsoleWrite($sDisplayName & @CRLF)
Next


For $i = 8 To 0 Step -1
    If FileExists(@SystemDir & "\msxml" & $i & ".dll") Then
        $oXML = ObjCreate("Msxml2.DOMDocument." & $i & ".0")
        If IsObj($oXML) Then
            $DOMVERSION = "Msxml2.DOMDocument." & $i & ".0"
            ConsoleWrite($DOMVERSION & @CRLF)
        Else
            ContinueLoop
        EndIf
    Else
        ContinueLoop
    EndIf

    $xml = '<?xml version="1.0"?><DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname' & $DOMVERSION & '-a" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>'
    $oXML.loadxml($xml)
    ConsoleWrite($oXML.xml)
    For $oConfig in $oXML.selectNodes("//DeploymentConfiguration")
        $sDisplayName = $oConfig.getAttribute('DisplayName')
        ConsoleWrite($sDisplayName & @CRLF)
    Next

    $xml = '<?xml version="1.0"?><DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname' & $DOMVERSION & '-b" ></DeploymentConfiguration>'
    $oXML.loadxml($xml)
    ConsoleWrite($oXML.xml)
    For $oConfig in $oXML.selectNodes("//DeploymentConfiguration")
        $sDisplayName = $oConfig.getAttribute('DisplayName')
        ConsoleWrite($sDisplayName & @CRLF)
    Next

    ConsoleWrite(@CRLF & @CRLF)
Next

no idea why...output:

<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname1" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>
testDisplayname1


<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplayname2"></DeploymentConfiguration>

testDisplayname2
Msxml2.DOMDocument.6.0
<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplaynameMsxml2.DOMDocument.6.0-a" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>
<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplaynameMsxml2.DOMDocument.6.0-b"></DeploymentConfiguration>
testDisplaynameMsxml2.DOMDocument.6.0-b


Msxml2.DOMDocument.4.0
<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplaynameMsxml2.DOMDocument.4.0-a" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>
<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplaynameMsxml2.DOMDocument.4.0-b"></DeploymentConfiguration>
testDisplaynameMsxml2.DOMDocument.4.0-b


Msxml2.DOMDocument.3.0
<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplaynameMsxml2.DOMDocument.3.0-a" xmlns="http://schemas.microsoft.com/appv/2010/deploymentconfiguration"></DeploymentConfiguration>
testDisplaynameMsxml2.DOMDocument.3.0-a
<?xml version="1.0"?>
<DeploymentConfiguration PackageId="testID" DisplayName="testDisplaynameMsxml2.DOMDocument.3.0-b"></DeploymentConfiguration>
testDisplaynameMsxml2.DOMDocument.3.0-b
Edited by jdelaney

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites
someone

Thanks for going this far with it... I'm trying to figure out the difference of why it would work in 3 but not 6, and I'll post back on this thread if I get anywhere.  And PS you were right , using just load() I can load up an XML based on filepath, instead of passing a string with loadxml().


While ProcessExists('Andrews bad day.exe')
	BlockInput(1)
	SoundPlay('Music.wav')
	SoundSetWaveVolume('Louder')
WEnd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • ijourneaux
      By ijourneaux
      I am trying to read an XML file that looks like the following. I am particularly interested in the ParameterNames and ParameterValues
       
      I was able to read a simplier XML file using
      $oXML.load("DataForwardSettings.xml") Local $oInfos = $oXML.selectnodes("//Database") ; or //Info or //Data//Info or //Values/Info  but have not been able to read
      <?xml version="1.0"?> <Entities> <Entity RecordType="TrendData"> <Property Name="AlarmLimitsSetNumber" IsReadOnly="False" ValueType="System.Int32">8</Property> <Property Name="AnalysisParamaterSetNumber" IsReadOnly="False" ValueType="System.Int32">8</Property> <Property Name="ParameterNames" IsReadOnly="True" IsList="True" ListType="List<string>" ValueType="Array" ArrayType="System.String" Count="12">System.Collections.Generic.List`1[System.String]<Data>OVERALL|PK-PK WAVEFORM|HFD|CREST FACTOR|SYNC 1-6|1X|2X|3X-4X|FTF|BSF|BPFO|BPFI</Data></Property> <Property Name="ParameterValues" IsReadOnly="True" IsList="True" ListType="List<float>" ValueType="Array" ArrayType="System.Single" Count="12">System.Collections.Generic.List`1[System.Single]<Data>0.04706,0.27951,0.02640,4.85608,0.03494,0.01727,0.02256,0.01993,0.00207,0.00060,0.00178,0.00221</Data></Property> <Property Name="NumberOfParameters" IsReadOnly="False" ValueType="System.Int32">12</Property> <Property Name="ModifiedSinceLastDataDump" IsReadOnly="False" ValueType="System.Boolean">False</Property> <Property Name="Load" IsReadOnly="False" ValueType="System.Single">0</Property> <Property Name="RPM" IsReadOnly="False" ValueType="System.Single">140.962</Property> <Property Name="Value" IsReadOnly="False" ValueType="System.Single">-1.1E-20</Property> <Property Name="SampleID" IsReadOnly="False" ValueType="System.Int32">-626794</Property> <Property Name="Timestamp_as_String" IsReadOnly="True" ValueType="System.String">8/18/2018 2:05:33 PM</Property> <Property Name="Timestamp_as_UInt" IsReadOnly="False" ValueType="System.UInt32">1534619133</Property> <Property Name="Timestamp" IsReadOnly="False" ValueType="System.DateTime">8/18/2018 2:05:33 PM</Property> <Property Name="StorageFlag" IsReadOnly="False" ValueType="Enum" EnumType="Emerson.CSI.DataImport.MHM.TrendDataStorageType" EnumValue="2">RPM_And_Overall</Property> <Property Name="Parents" IsReadOnly="False" IsList="True" ListType="List<string>" ValueType="Array" ArrayType="System.String" Count="5">System.Collections.Generic.List`1[System.String]<Data>Database=phmhmdb4ts;C:\RBMdbsrv\CustData\4ts_online_1807.rbm;-99|Area=4TS;-494|Equipment=4THTS;-712|MeasurementPoint=D39;-780|DataCollectionSet=Normal Collection Dryer Rolls;-783</Data></Property> </Entity> </Entities> I tried switching to the XML UDF but was alittle lost in how to use it. I am particularly interested in the ParameterNames and ParameterValues.
    • macran
      By macran
      I want to generating a XML file (test.xml) like as follow:
      <?xml version="1.0" encoding="GBK"?>
      <!DOCTYPE SCHEMA SYSTEM "HGWSPZJK.dtd">  ;I can not generate this line
      <SCHEMA CRC="HGWSPZ201808_9131011571786229XM_CRC.XML" SSSQ="201808" CHSNAME="HGWSDKQD" NAME="HGWSPZ">

      <TAXPAYER CJRMC="sigmagroup" CJRDM="9131011571786229XM" CJLX="DKZK" RECORDCOUNT="411" SBRQ="2018-08-31" NSRMC="sigmagroup" SWSBH="9131011571786229XM">

      <Records>
      <Record BZ="" JKKADM="2244" JKKAMC="shanghai" SE="5907.82" TFRQ="2018-08-23" FPHM="224420181000752586-L02"/>
      <Record BZ="" JKKADM="2244" JKKAMC="shanghai" SE="4742.4" TFRQ="2018-08-21" FPHM="224420181000743016-L01"/>
      <Record BZ="" JKKADM="2244" JKKAMC="shanghai" SE="18720" TFRQ="2018-08-14" FPHM="224420181000719215-L01"/>
      </Records>
      </TAXPAYER>
      </SCHEMA>
      I use XML.UDF  
      Local $oXMLile=_XML_CreateFile(@ScriptDir&"\test.xml","",True) 
      but there is no function CreateDocumentType 
      It is no effort even I test use 
      Local $doct=$oXMLfile.CreateDocumentType("SCHEMA", null, "HGWSPZJK.dtd", null)
            $oXmlfile.appendChild($doct)
      pls help me thanks.
       
       
       
       
       
       
    • Skeletor
      By Skeletor
      Hi All,
      This is purely an XML Language question. I need to understand how I can add a value/element in between another XML element. 
      Code below shows the XML file. The info tag has the elements already inserted.
      <Configuration xmlns="http://schemas.datacontract.org/2004/07/Modules.Reporting.DataContracts.LineItems" xmlns:i="http://www.w3.org/2001/XMLSchema-instance"> <GenConf> <Info>ID, Site, Name , Site_ID</Info> </GenConf> </Configuration> Now, I want to add a value from a node group into this code. Something like below. But the example below does not work.
      Any suggestions?
       
      <Configuration xmlns="http://schemas.datacontract.org/2004/07/Modules.Reporting.DataContracts.LineItems" xmlns:i="http://www.w3.org/2001/XMLSchema-instance"> <GenConf> <Info>ID, Site, a/@id, Name , Site_ID</Info> </GenConf> </Configuration> <ProductName> <a id="Windows Server"/> </ProductName>  
    • bhns
      By bhns
      try it for make flyers old games xml + Gdi, i belive many sources had lost 
      AIT-ADRLIST.au3

    • CosminV
      By CosminV
      Hello guys,
       
      This XML things are driving me crazy...
      Please let me know how can I use the _XMLGetAttrib function... I've tried every possible way that I've read on the forum and I cannot succeed reading an attribute.
       
      The XML looks like bellow:
       
      <?xml version="1.0" encoding="UTF-8"?>
      <BATCH attr1= "aaa" attr2="bbb" attr3="ccc">
           <Node1 attr1="aaa" attr2="bbb" attr3="ccc" attr4="ddd" attr5="" attr6="eee" attr7="fff" attr8="ggg"/>
           <Node2 attr1="aaa" attr2="" attr3="" attr4="ddd"/>
           <Node3 attr1="" attr2="" attr3="ccc" attr4="" attr5="" attr6="eee"/>
           <Panel attr1="aaa" STATUS="BBB" attr3="ccc" attr4="ddd" attr5="" attr6="eee">
                <Node5 attr1="aaa" attr2="bbb" attr3="ccc" attr4="ddd" attr5="" attr6="eee" attr7="fff" attr8="ggg"/>
                .............................................................................................................................................................................
           </Panel>
      </Batch>
       
      I need to read the value of STATUS form the Panel node.
       
      Could you please help me?
       
      Best regards,
      Cococnb
×