Jump to content
Sign in to follow this  
perfaram

Using resource DLLs

Recommended Posts

perfaram

Hi all !
I'm trying to use resource DLLs, created with this script : '?do=embed' frameborder='0' data-embedContent>>
Using the well-known resource.au3.
Sadly, I cannot use any of the included resource - regardless the kind
RC_BITMAP (with _ResourceGetAsBitmap)
RC_STRING (with _ResourceGetAsString)
(I can see them through ResourceHacker)

It's been 5 days since I started trying - I read a bunch of threads, in this forum as well as in the french and german ones.

Note : I'm trying to use the icons with ITaskBarList UDF, and the texts are translations.
Thanks in advance for any help !

EDIT : Here's the code :

$rst = _ResourceGetAsString(@OSLang, $RT_RCDATA, @OSLang, @ScriptDir&"\res\LISBON_res.dll")
MsgBox(32, "String", $rst) ; Empty MsgBox !!
$rsa = StringSplit($rst, @CRLF)
_ArrayDisplay($rsa) ; Returns an empty array - except the number of rows in the array

Here's the DLL file : 

LISBON_res.zip

Edited by perfaram

Never forget to mark a question as resolved, this button has been purposely created :-P 

Share this post


Link to post
Share on other sites
perfaram

OKAY !! I'll close the topic, since I found why it wasn't working (some little - but annoying - errors, not related to AutoIT nor to DLLs.


Never forget to mark a question as resolved, this button has been purposely created :-P 

Share this post


Link to post
Share on other sites
Tlem

Can you share your solution ... And close the french topic. :whistle:

  • Like 1

Best Regards.Thierry

Share this post


Link to post
Share on other sites
perfaram

Okay Tlem, so here it is :

- Firstly, @OSLang didn't match the resource name in the DLL : @OSLang returns the hexl value of what I wanted (e.g. 0409 instead of 1033)

- Second thing, the resources had an "1" at the end of their names (e.g. 04091 instead of 0409)

- Finally, the resource language were setted to english, regardless of their real language.

So, let's pack up all that :

Global $rst = _ResourceGetAsString(@OSLang & "1", $RT_RCDATA, Dec(@OSLang), @ScriptDir & "\Res\LISBON_res.dll")

Thanks a lot to you, tlem, for your help on the french forum.

Edited by perfaram

Never forget to mark a question as resolved, this button has been purposely created :-P 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.