Sign in to follow this  
Followers 0
toolsqa

Function is never closed in your script

3 posts in this topic

Hi,

I know this would be a a very simple and stupid question but as a newbee I am not able to resolve this error. Please help.

AutoIT_Selenium_Firefox_IE_Chrome_Authentication("Authentication Required","OK") Func AutoIT_Selenium_Firefox_IE_Chrome_Authentication($winTitle, $buttonName) WinWaitActive($winTitle) If WinExists($winTitle, "") Then Sleep(2000) Send("User") Send("{TAB}") Send("Password") Sleep(2000) Send("{TAB}") Send("{ENTER}") Sleep(2000) EndIf EndFunc


;### Tidy Error -> func is never closed in your script.

If I run this script it displays error "Unknown Function Name".

Regards,

ToolsQA

Share this post


Link to post
Share on other sites

AutoIT_Selenium_Firefox_IE_Chrome_Authentication("Authentication Required", "OK")
Func AutoIT_Selenium_Firefox_IE_Chrome_Authentication($winTitle, $buttonName)
    WinWaitActive($winTitle)
    If WinExists($winTitle, "") Then
        Sleep(2000)
        Send("User")
        Send("{TAB}")
        Send("Password")
        Sleep(2000)
        Send("{TAB}")
        Send("{ENTER}")
        Sleep(2000)
    EndIf
EndFunc   ;==>AutoIT_Selenium_Firefox_IE_Chrome_Authentication

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0