Jump to content
Sign in to follow this  

Problem with ControlListView returning 0 in Quicktime Pro

Recommended Posts


Hi - I'm attempting to write a script that will automate selection of channel assignments for multichannel Quicktime files, and I've hit a sticking point that I can't seem to get past.

My problem is in the drop-down list in the QT Pro Properties panel. It's listed by the AutoIt window info as being CLASS:ATL:SysListView32, but every ControlListView command I attempt to send it returns 0, including GetItemCount. I've also tried ControlCommand to no avail. I have no issue sending and receiving commands anywhere else in the QT Properties panel, but this ATL:SysListView32 refuses to cooperate. All I need to be able to do is send a ("Select", 1) command to choose a channel assignment.

I searched for other people having this issue with ATL:SysListView's, but none of the questions were ever answered and they're all 5+ years old.

Any ideas!


Here's a summary dump from Window Info.

>>>> Window <<<<
Title: Properties
Class: MPGenericPaneClass
Position: 200, 200
Size: 620, 596
Style: 0x16CF0000
ExStyle: 0x00000100
Handle: 0x009D0834
>>>> Control <<<<
Class: ATL:SysListView32
Instance: 1
ClassnameNN: ATL:SysListView321
Advanced (Class): [CLASS:ATL:SysListView32; INSTANCE:1]
ID: 1819702131
Position: 394, 186
Size: 170, 341
ControlClick Coords: 72, 31
Style: 0x56818001
ExStyle: 0x00000200
Handle: 0x002E0950
>>>> Mouse <<<<
Position: 674, 447
Cursor ID: 2
Color: 0xFFFFB6
>>>> StatusBar <<<<
>>>> ToolsBar <<<<
>>>> Visible Text <<<<
>>>> Hidden Text <<<<
Edited by yevlar

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.