Sign in to follow this  
Followers 0
Chimaera

Compile error using #AutoIt3Wrapper_Res_requestedExecutionLevel=requireAdministrator

8 posts in this topic

I have 2 scripts that i just altered to use Admin and neither script will accept it

every time i compile with options i get this error

One of them is as simple as this

#Region ;**** Directives created by AutoIt3Wrapper_GUI ****
#AutoIt3Wrapper_Icon=compile\chimaera.ico
#AutoIt3Wrapper_Outfile=capture_msconfig.exe
#AutoIt3Wrapper_Res_Description=Aggregates msconfig keys.
#AutoIt3Wrapper_Res_LegalCopyright=Created by Chimaera
#AutoIt3Wrapper_Res_Language=1033
#AutoIt3Wrapper_Res_requestedExecutionLevel=requireAdministrator
#AutoIt3Wrapper_AU3Check_Parameters=-d -w 1 -w 2 -w 3 -w- 4 -w 5 -w 6 -w- 7
#EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****
#include <MsgBoxConstants.au3>

Global $runcapture = ShellExecute(@ScriptDir & '\whatinstartup.exe', ' /scomma .\Logs\msconfig_logs\' & @OSVersion & '-' & @UserName & '-' & @MDAY & '-' & @MON & '-' & @MIN & '-' & @SEC & '.csv')

MsgBox($MB_ICONINFORMATION, 'Msconfig Capture Has Finished', @UserName & ' ' & @MDAY & ' ' & @MON & ' ' & @MIN & ' ' & @SEC & '.csv Created', 3)

 

Error: EndUpdateResource: Returncode = 0 - LastError:1359:An internal error occurred.

 

 

If i hide that line it compiles fine

Also i just noticed i have no right click options on the au3 file for just normal run or compile not beta

Share this post


Link to post
Share on other sites



#3 ·  Posted (edited)

>"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "L:\#   Tailored\Log PC\Msconfig\capture_msconfig.au3" /UserParams    
+>11:53:14 Starting AutoIt3Wrapper v.2.1.4.4 SciTE v.3.3.7.0 ;  Keyboard:00000809  OS:WIN_81/  CPU:X64 OS:X64    Environment(Language:0409  Keyboard:00000809  OS:WIN_81/  CPU:X64 OS:X64)
>Running AU3Check (3.3.12.0)  params:-d -w 1 -w 2 -w 3 -w- 4 -w 5 -w 6 -w- 7  from:C:\Program Files (x86)\AutoIt3
+>11:53:14 AU3Check ended.rc:0
>Running:(3.3.12.0):C:\Program Files (x86)\AutoIt3\autoit3.exe "L:\#   Tailored\Log PC\Msconfig\capture_msconfig.au3"    
--> Press Ctrl+Alt+F5 to Restart or Ctrl+Break to Stop
+>11:53:17 AutoIt3.exe ended.rc:0
+>11:53:17 AutoIt3Wrapper Finished..
>Exit code: 0    Time: 3.605

Thats if i try and run it

But i only get the error no log out put at all in the window when i compile with options

I dont understand why my compile script (no beta) is missing

Edited by Chimaera

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

This is the output from Run ... not Compile!

Have you excluded the temp dir AutoIt3 uses from your AntiVirus program? (%localappdata%AutoIt v3)

When using the standard installers you will get the appropriate right-mouse-click options.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

>"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /ShowGui /in "L:#   TailoredLog PCMsconfigcapture_msconfig.au3"
+>16:40:29 Starting AutoIt3Wrapper v.2.1.4.4 SciTE v.3.3.7.0 ;  Keyboard:00000809  OS:WIN_81/  CPU:X64 OS:X64    Environment(Language:0409  Keyboard:00000809  OS:WIN_81/  CPU:X64 OS:X64)
-> No changes made..
>Running AU3Check (3.3.12.0)  params:-d -w 1 -w 2 -w 3 -w- 4 -w 5 -w 6 -w- 7  from:C:Program Files (x86)AutoIt3
+>16:40:37 AU3Check ended.rc:0
>Running:(3.3.12.0):C:\Program Files (x86)\AutoIt3\Aut2Exe\aut2exe.exe  /in "L:#   TailoredLog PCMsconfigcapture_msconfig.au3" /out "C:Users****AppDataLocalAutoIt v3Aut2exe~AU3fqnpmwr.exe" /nopack /icon "compilechimaera.ico" /comp 2
+>16:40:38 Aut2exe.exe ended.C:Users****AppDataLocalAutoIt v3Aut2exe~AU3fqnpmwr.exe. rc:0
>16:40:38 Performing the Program Resource Update steps:
...>Updating Program Version information.
...>Setting Program ExecutionLevel Manifest information to requireAdministrator
...>Setting Program Compatibility Manifest information to Windows8.1
UpdateResources other: $result[0] = 0 - LastError:1359:An internal error occurred.
...>Updating Program Manifest information.
!>16:40:38 Error: EndUpdateResource: Returncode = 0 - LastError:1359:An internal error occurred.rc:2
!>16:40:38 Error: Program Resource updating Failed. The output program will not contain the Resource updates!rc:2
+>16:40:41 Created program:L:#   TailoredLog PCMsconfigcapture_msconfig.exe
+>16:40:41 AutoIt3Wrapper Finished..
>Exit code: 0    Time: 12.919

 

 

It gives the error and if you choose stop it quits no output

If you continue it completes the file but im not sure the file is admin, ill take them to work to check tommoz

Im missing all the standard options on right click see below

post-60350-0-24731200-1424018242_thumb.p

Av has been disabled for testing and i still get the error

Edited by Chimaera

Share this post


Link to post
Share on other sites

Your version of AutoIt3Wrapper is rather old so give the last version a try first as there has been some fixes for the resource update process in the mean time.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

That seems to have cured it its got the uac symbol on the exe now and no errors so it appears to have worked

Should i reinstall autoIt to get it all up to date?, didnt think i was behind but clearly something changed

 

Many thanks

Share this post


Link to post
Share on other sites

That seems to have cured it its got the uac symbol on the exe now and no errors so it appears to have worked

Should i reinstall autoIt to get it all up to date?, didnt think i was behind but clearly something changed

The full SciTE4AutoIt3 setup is a separate installer which I update regularly and isn't following the AutoIt3 installer releases,

Just look in the DEV forum sticky about it for updates.

Jos 


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0