Sign in to follow this  
Followers 0
YouriKamps

Debugging not working

2 posts in this topic

#1 ·  Posted (edited)

Hello all,

For some strange reason #AutoIt3Wrapper_run_debug_mode=Y is only working in some of my scripts... Reinstalled both Autoit and Scite4autoit3 but it's still not working yet it used to work some time ago.

The script that doesn't work gives me this output (after this output it continues running the script without debug):

>"C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "G:\LSD Scripts\LSD Scripts 1\LSD Scripts 1.au3" /UserParams    
+>14:41:41 Starting AutoIt3Wrapper v.14.801.2025.0 SciTE v.3.4.4.0   Keyboard:00000409  OS:WIN_7/Service Pack 1  CPU:X64 OS:X86    Environment(Language:0413)
+>         SciTEDir => C:\Program Files\AutoIt3\SciTE   UserDir => C:\Users\kamps495\AppData\Local\AutoIt v3\SciTE\AutoIt3Wrapper   SCITE_USERHOME => C:\Users\kamps495\AppData\Local\AutoIt v3\SciTE 
>Running AU3Check (3.3.12.0)  from:C:\Program Files\AutoIt3  input:G:\LSD Scripts\LSD Scripts 1\LSD Scripts 1.au3
+>14:41:41 AU3Check ended.rc:0
>Running:(3.3.12.0):C:\Program Files\AutoIt3\autoit3.exe "G:\LSD Scripts\LSD Scripts 1\LSD Scripts 1.au3"    
--> Press Ctrl+Alt+Break to Restart or Ctrl+Break to Stop
!> Starting in DebugMode..
Line: @error-@extended: Line syntax
+>14:41:43 AutoIt3.exe ended.rc:0
+>14:41:43 AutoIt3Wrapper Finished.
>Exit code: 0    Time: 1.807

Another script (same Scite, different tab) gives me this:

>"C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "G:\LSD Scripts\Mousemover\mousemover.au3" /UserParams    
+>14:48:14 Starting AutoIt3Wrapper v.14.801.2025.0 SciTE v.3.4.4.0   Keyboard:00000409  OS:WIN_7/Service Pack 1  CPU:X64 OS:X86    Environment(Language:0413)
+>         SciTEDir => C:\Program Files\AutoIt3\SciTE   UserDir => C:\Users\kamps495\AppData\Local\AutoIt v3\SciTE\AutoIt3Wrapper   SCITE_USERHOME => C:\Users\kamps495\AppData\Local\AutoIt v3\SciTE 
>Running AU3Check (3.3.12.0)  from:C:\Program Files\AutoIt3  input:G:\LSD Scripts\Mousemover\mousemover.au3
+>14:48:15 AU3Check ended.rc:0
>Running:(3.3.12.0):C:\Program Files\AutoIt3\autoit3.exe "G:\LSD Scripts\Mousemover\mousemover.au3"    
--> Press Ctrl+Alt+Break to Restart or Ctrl+Break to Stop
!> Starting in DebugMode..
Line: @error-@extended: Line syntax
0001: 0-0: #Region ;**** Directives created by AutoIt3Wrapper_GUI ****
0002: 0-0: #AutoIt3Wrapper_run_debug_mode=Y ;y = debug aan, n = debug uit
0003: 0-0: #EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****
0004: 0-0: Opt("WinWaitDelay", 1000)

and gives me line-by-line debug. Both have the same directives at the top:

#Region ;**** Directives created by AutoIt3Wrapper_GUI ****
#AutoIt3Wrapper_run_debug_mode=Y ;y = debug aan, n = debug uit
#EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****

I can't figure it out for the life of me...

EDIT:

It seems that adding #RequireAdmin ANYWHERE near the beginning of the script (before or after the #Region-part) breaks the debug. I really need #RequireAdmin (without it Internet Explorer crashes on me), but I cannot debug. When adding #RequireAdmin I can run my script, but I cannot debug it...

Edited by YouriKamps

Share this post


Link to post
Share on other sites



You can't use ConsoleWrite and #RequireAdmin in the same script from Scite unless you also start Scite as an administrator.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0