Jump to content
Sign in to follow this  
Champak

Problems with object scroll only after compile

Recommended Posts

Champak

Need some help please. I'm using windows 8.1 pro, the latest autoit. When I run my through scite, everything runs fine, when I run my app compiled the controls of the wmp object show even though I have them programmed not to show. Any idea why this only happens compiled. I made two changes to my system prior to this, changed to an SSD HD, and changed from win7 to win8.1, it never happened on my old system. And it is barebones. Any ideas? Thanks.

image attached.

image.jpg

Edited by Champak
Edit title

Share this post


Link to post
Share on other sites
Champak

Its 20,000 lines, but Here is the portion that the visualization is created.

$MEDIA_PLAYER_ARRAY[18] = GUICtrlCreateObj($OIE_AD2, 0, 0, $MVWidth, $MVHeight-95)
        GUICtrlSetColor(-1, 0x000000)
        GUICtrlSetBkColor(-1, 0x000000)
        _IENavigate($OIE_AD2, "about:blank", 1)
        _IELoadWait($OIE_AD2, 180, 4000)
        Do
            Sleep(50)
            $ODOC_AD2 = $OIE_AD2.document
        Until IsObj($ODOC_AD2)
        Sleep(25)
        $OBODY_AD2 = $ODOC_AD2.body
        $OBODY_AD2.scroll = "no"
        $OBODY_ADSTYLE2 = $OBODY_AD2.style
        With $OBODY_ADSTYLE2
            .margin = "0px"
            .border = "0px"
            .padding = "0px"
            .backgroundcolor = "#ff0000"
        EndWith

        $OPLAYER1 = $ODOC_AD2.createElement("OBJECT")
        With $OPLAYER1
            .style.width = $MVWidth

            .style.height = $MVHeight-20
            .style.background = "#000000"
            .classid = "CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6"
            .uiMode = "none"
            ;.showstatusbar = "false"
            ;.showdisplay = "false"
            .settings.setMode("loop", "false")
            .settings.autostart = True
        EndWith

        $OBODY_AD2.appendChild($OPLAYER1)

Something tells me tells me its some obscure setting in windows interacting with the exe. But I don't know. I don't want to go back to win7 because of this.

Edited by Champak

Share this post


Link to post
Share on other sites
Champak

It turns out it is not the uimode hiding being the issue (although it is not working, and I've actually seen other people on the net with the uimode problem) but actually the "scroll = no" not working. How do I know? I took the compiled script to another computer that wasn't showing the control with win8.1 and commented out the "scroll = no" and the scroll bars popped up, and I could see the control at the bottom even though I still had "uimode = none". So, it seems the scroll bar code is just not working on one computer and the control hide isn't working period. So I need to figure out why the "scroll = no" portion of the code won't work while compiled on one computer. Any ideas? I don't know how to begin to google for something like this.

Edited by Champak

Share this post


Link to post
Share on other sites
Champak

Fixed it...somewhat. The "scroll = no" and "uimode = none" still doesn't work, so I added "overflow = hidden" right before the "margin = 0px". So that basically has hidden the control and gotten rid of my scroll bars. However the issue still remains as to:

A/ Why can't the control be hidden with uimode = none? (although I think this is beyond an autoit issue)

B/ Why does "scroll = no" stop working in my app once compiled but works perfectly fine through scite?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×