Dub333

_IESubmitForm not working in IE 11

5 posts in this topic

Where I work I'm trying to get my script to work with IE11, but _IESubmitForm that worked on the PC with IE8 (yes old version), doesn't work on on the PC with IE11.

Thoughts on how to get it to work with IE 11?

Thanks!

Share this post


Link to post
Share on other sites



So, thought I'd add the part of the code I am having the issue with: (Sorry, can't post the real URL)

 

$oIE = _IECreate("http://workwebsite.asp", 1, 1, 0, 1)                      ;<--- This works
            ;_IELoadWait($oIE)                                              ;<-- Tried putting this in and it didn't help
            Sleep(10000)    ;Wait 10 seconds for webpage to open            ;<--- This works
            $oForm = _IEFormGetObjByName($oIE, "Main1")                     ;<--- This works
            $oQuery = _IEFormElementGetObjByName ($oForm, "SearchName")     ;<--- This works
            ;Search Name is entered on the form
            _IEFormElementSetValue ($oQuery, $Page_List)                    ;<--- This works, name is entered
            Sleep(3000)                                                     ;<--- This works
            _IEFormSubmit ($oForm, 0)                                       ;<--- This only works in IE 8, webpage just sits in IE 11

 

Not sure any of this will help with getting my issue resolved, but thought I'd try adding it to see if anyone can come up with something I can try.

Thanks for any help that anyone can provide.

Share this post


Link to post
Share on other sites

You can always try using: 

_IEAction()

on the element with a 'click' action. 


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites

i wonder , can i send a click to a link on firefox ,chrome , ie browser?

Share this post


Link to post
Share on other sites

You can always try using: 

_IEAction()

on the element with a 'click' action. 

i wonder , can i send a click to a link on firefox ,chrome , ie browser? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now