Jump to content
Sign in to follow this  
Progh0st

API Upload XML WinHttp

Recommended Posts

I'm trying to use Sendspace API for download and upload, until now i only have learned to get token, login and get session key. My next step is upload a file. But i have no idea how to do this part.

; try to upload something

; Specify the reguest to upload.getInfo:
Local $hRequest = _WinHttpOpenRequest($hConnect, Default, "/rest/?method=upload.getinfo&session_key=" & $SessonKey & "&speed_limit=0")

; Send request
Local $handle = _WinHttpSendRequest($hRequest)

; Wait for the response
Local $WaitRS = _WinHttpReceiveResponse($hRequest)

; Read Data
Local $sData = _WinHttpReadData($hRequest)
MsgBox(0, "Upload Data", $sData)
_filewrite($sData)

; Get all info needed from $sData

$URL = _StringBetween($sData, "<upload url=", "progress")
$sURL = $URL[0]

$MaxFileSize = _StringBetween($sData, "max_file_size=", "progress")
$sMaxFileSize = $MaxFileSize[0]

$Upload_Identifier = _StringBetween($sData, "upload_identifier=", "&amp")
$sUpload_Identifier = $Upload_Identifier[0]

$ExtraInfo = _StringBetween($sData, "extra_info=", "/>")
$sExtraInfo = $ExtraInfo[0]

;All well done until here

;Fill in form

$XML = '<form method="post" action="' & $sURL &  'enctype="multipart/form-data">' & @CRLF
$XML &= '<input type="hidden" name="MAX_FILE_SIZE" value=' & $sMaxFileSize & '>' & @CRLF
$XML &= '<input type="hidden" name="UPLOAD_IDENTIFIER" value=' & $sUpload_Identifier & '>' & @CRLF
$XML &= '<input type="hidden" name="extra_info" value=' & $sExtraInfo & '>' & @CRLF
$XML &= '<input type="file" name=' & "C:\Users\Arlen\Desktop\premisa mrotal.txt" & '>' & @CRLF
$XML &= '</form>'
MsgBox(0,"", $XML)

; Now how do i send it? Is it correct?


_WinHttpCloseHandle($hRequest)
_WinHttpCloseHandle($hConnect)
_WinHttpCloseHandle($hOpen)

 

sendspace_api_guide.pdf

Edited by Progh0st
Added PDF of sendspace if helpful

Share this post


Link to post
Share on other sites
$sFileToUpload = "C:\Users\Arlen\Desktop\premisa mrotal.txt"

$XML = '<form method="post" action="' & $sURL &  '" enctype="multipart/form-data">' & @CRLF
$XML &= '<input type="hidden" name="MAX_FILE_SIZE" >' & @CRLF
$XML &= '<input type="hidden" name="UPLOAD_IDENTIFIER" >' & @CRLF
$XML &= '<input type="hidden" name="extra_info" >' & @CRLF
$XML &= '<input type="file" name="userfile" >' & @CRLF
$XML &= '</form>'

$hConnect = $XML ;<!!!

; Fill the form
$sHTML = _WinHttpSimpleFormFill($hConnect, $hOpen, _
        Default, _
        "name:MAX_FILE_SIZE", $sMaxFileSize, _
        "name:UPLOAD_IDENTIFIER", $sUpload_Identifier, _
        "name:extra_info", $sExtraInfo, _
        "name:userfile", $sFileToUpload)

;...

 

Edited by trancexx

Share this post


Link to post
Share on other sites
$sFileToUpload = "C:\Users\Arlen\Desktop\premisa mrotal.txt"

$XML = '<form method="post" action="' & $sURL &  '" enctype="multipart/form-data">' & @CRLF
$XML &= '<input type="hidden" name="MAX_FILE_SIZE" >' & @CRLF
$XML &= '<input type="hidden" name="UPLOAD_IDENTIFIER" >' & @CRLF
$XML &= '<input type="hidden" name="extra_info" >' & @CRLF
$XML &= '<input type="file" name="userfile" >' & @CRLF
$XML &= '</form>'

$hConnect = $XML ;<!!!

; Fill the form
$sHTML = _WinHttpSimpleFormFill($hConnect, $hOpen, _
        Default, _
        "name:MAX_FILE_SIZE", $sMaxFileSize, _
        "name:UPLOAD_IDENTIFIER", $sUpload_Identifier, _
        "name:extra_info", $sExtraInfo, _
        "name:userfile", $sFileToUpload)

;...

 

It looks good, but for some reason i get this code error: 5 API_ERROR_BAD_API_VERSION Unknown or unsupported API version

You can check it out on the pdf, i also send them support ticket, waiting for response

Edited by Progh0st

Share this post


Link to post
Share on other sites

As a side note, you should learn how to better take advantage of the language you use. For example by writing more generic functions and using them in your code. One good function would be to parse simple xml data that the API returns instead of using _StringBetween() like you do. If I were you I would write this function:

Func ReadXMLData($sXML, $sTag)
    Local $aData = StringRegExp($sXML, "(?si)<\s*" & $sTag & "(?:[^\w])\s*(.*?)(?:(?:<\s*/" & $sTag & "\s*>)|\Z)", 3)
    If @error Then Return ""
    Return $aData[0]
EndFunc

...and then use it like this:

$sToken = ReadXMLData($sData, "token")
;...
$sSessionKey = ReadXMLData($sData, "session_key")
;...
$sUploadData = ReadXMLData($sData, "upload")
;...and then:
$MAX_FILE_SIZE = __WinHttpAttribVal($sUploadData, "max_file_size")
$UPLOAD_IDENTIFIER = __WinHttpAttribVal($sUploadData, "upload_identifier")
$sExtraInfo = __WinHttpAttribVal($sUploadData, "extra_info")
;...

 

Also, I would use _WinHttpSimpleFormFill() for every step/method. Starting from auth.createtoken through auth.login and all the way to upload.getInfo before uploading the file. That way you could switch to https with no trouble (or changes to the code) because form filling function handles all protocols in a seamless way. 

 

 

Edited by trancexx

Share this post


Link to post
Share on other sites

Thank you so much this will be very useful for me and save time!

I have one more question. How can i upload and at the same time get the progressbar working, since i have to wait for it to upload first to continue with the script. Ty

Share this post


Link to post
Share on other sites

You will always have to wait for upload to finish before continuing in AutoIt. The language isn't capable for parallel executions.

What I can do is add new function to WinHttp.au3 that could be used to set callback function that would be called during upload process periodically, in which you could control/update progress bar or whatever.
Yea, I think I'll do that.

Share this post


Link to post
Share on other sites

Ok, done. The example would be:

#include "WinHTTP.au3"

$sAddress = "https://posttestserver.com/post.php?dir=WinHttp" ; the address of the target (https or http, makes no difference - handled automatically)

; Select some file
$sFileToUpload = FileOpenDialog("Select file to upload...", "", "All Files (*)")
If Not $sFileToUpload Then Exit 5 ; check if the file is selected and exit if not

$sForm = _
        '<form action="' & $sAddress & '" method="post" enctype="multipart/form-data">' & _
        ' <input type="file" name="upload"/>' & _
        '</form>'

; Initialize and get session handle
$hOpen = _WinHttpOpen()

$hConnect = $sForm ; will pass form as string so this is for coding correctness because $hConnect goes in byref

; Creates progress bar window
ProgressOn("UPLOADING", $sFileToUpload, "0%")

; Register callback function
_WinHttpSimpleFormFill_SetCallback(UploadCallback)

; Fill form
$sHTML = _WinHttpSimpleFormFill($hConnect, $hOpen, _
        Default, _
        "name:upload", $sFileToUpload)
; Collect error number
$iErr = @error

; Unregister callback function
_WinHttpSimpleFormFill_SetCallback(0)

; Kill progress bar window
ProgressOff()

; Close handles
_WinHttpCloseHandle($hConnect)
_WinHttpCloseHandle($hOpen)

If $iErr Then
    MsgBox(4096, "Error", "Error number = " & $iErr)
Else
    ConsoleWrite($sHTML & @CRLF)
    MsgBox(4096, "Success", $sHTML)
EndIf



; Callback function. For example, update progress control
Func UploadCallback($iPrecent)
    If $iPrecent = 100 Then
        ProgressSet(100, "Done", "Complete")
        Sleep(800) ; give some time for the progress bar to fill-in completely
    Else
        ProgressSet($iPrecent, $iPrecent & "%")
    EndIf
EndFunc

And the latest (working version of) WinHttp.au3 is at https://raw.githubusercontent.com/dragana-r/autoit-winhttp/master/WinHttp.au3

Try it, maybe I leave it in.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By TrashBoat
      Im trying to iterate through a 2d array created by 
      ProcessList() function that returns a 2d array containing names and pid's, i wanted to filter through the names and delete entries that have "svchost.exe" and this is how i did it
      Func _Sanitize($array) For $x = 1 To UBound($array) - 1 ConsoleWrite($array[$x][0] & @CRLF) If $array[$x][0] == "svchost.exe" Then _ArrayDelete($array, $x) EndIf Next EndFunc ;==>_Sanitize And i get this error message
      What is wrong?
    • By gahhon
      Global Const $DIR_WA_FOLDER = @MyDocumentsDir & '\Whatsapp Extension' Global Const $DIR_SHORTCUT = @DesktopDir & '\WhatsappWeb.exe' Func _Create_Shortcut() Local $sMessage = "Creating shortcut " _Metro_SplashTextScreen(1, "", $sMessage) AdlibRegister("_Metro_LoopInProgress") If FileExists($DIR_WA_FOLDER) Then $iDelete = FileDelete($DIR_SHORTCUT) If $iDelete Then _FileWriteLog($LOG_INSTALLATION, "Debug: Desktop's shortcut is deleted.") Else _FileWriteLog($LOG_INSTALLATION, "Debug: Desktop's shortcut is not found. But, desktop's shortcut is still created.") EndIf If FileExists($DIR_WA_FOLDER & '\WhatsappWeb.exe') Then $iCreate = FileCreateShortcut($DIR_WA_FOLDER & '\WhatsappWeb.exe', $DIR_SHORTCUT) If $iCreate Then _Metro_MsgBox(0, "", "Desktop shortcut is now created!") _FileWriteLog($LOG_INSTALLATION, "Debug: Desktop's shortcut is created.") Else _Metro_MsgBox(0, "", "Desktop shortcut is failed to created!") _FileWriteLog($LOG_INSTALLATION, "Error: Fail to create shortcut.") EndIf Else _Metro_MsgBox(0, "", "Source not found!") _FileWriteLog($LOG_INSTALLATION, "Error: WhatsappWeb.exe is not found.") EndIf Else _Metro_MsgBox(0, "", "Source not found!") _FileWriteLog($LOG_INSTALLATION, "Error: Whatsapp Extension folder is not found.") EndIf AdlibUnRegister("_Metro_LoopInProgress") _Metro_SplashTextScreen(0) EndFunc So I do have a button to trigger this create shortcut to desktop.
      But after it created shortcut at desktop, I cannot execute the shortcut as it has no any response.
      Then I go try trigger the file at the source path @MyDocumentDir & '\Whatsapp Extension\WhatsappWeb.exe' and it work as expected.
      Then I go to check my log, and it shows:- (P/S: I already did trigger the function twice)
      2019-02-28 23:27:32 : Debug: Desktop's shortcut is not found. But, desktop's shortcut is still created. 2019-02-28 23:27:33 : Debug: Desktop's shortcut is created. 2019-02-28 23:28:40 : Debug: Desktop's shortcut is not found. But, desktop's shortcut is still created. 2019-02-28 23:28:41 : Debug: Desktop's shortcut is created. So based on my log shows, it failed to locate the shortcut, but it did exists there.
       
      P/S: This project is done developed weeks ago, every testing is passed. Is just somehow the executable cannot be execute.
       
       
      Any advise?
    • By chrweav86
      Here is an existing AS400 PCOM script that I have: 
      #include-once
      #cs ----------------------------------------------------------------------------
       UDF Header Title: _PCOMM
       UDF Header Version: 0.1.0
       AutoIt Version: 3.3.8.1
       Author:         Jason S. - Jewelry Supply, Inc.
       Script Function: PCOMM UDF Header
                          For use with IBM AS/400 - IBM OS/400 - IBM System i - IBM i application system.
                          This PCOMM UDF Header targets ASW - an ERP application suite written in IBM's RPG language (yuck!),
                          although it will work for any AS/400 system and is not ASW specific.
                          PCOMM allows injection of keystrokes into the datastream of
                          a running terminal/console application ("Green Screen" Console Emulator).
                              - Assumes Session 'A' but can be overriden using the aswConnect() function.
                          PCOMM allows observing of characters in the datastream of a running
                          terminal/console application ("Green Screen" Console Emulator).
                              - Assumes Session 'A' but can be overriden using the aswConnect() function.
      #ce ----------------------------------------------------------------------------
      Global $Session = "A"
      Global $Ps
      Global $Oia
      ; Specify session to connect to
      Func aswSetSession($nSession)
          $Session = $nSession
      EndFunc
      ; Connect to ASW
      ; @param $nSession - Specify session to connect to. Ex: "A"
      Func aswConnect($nSession = $Session)
          $Obj_ConnMgr = ObjCreate("PCOMM.autECLConnMgr")
          $OBJ_EmulSession = ObjCreate("PCOMM.autECLSession")
          $OBJ_EmulSession.SetConnectionByName($nSession)
          $Ps = $OBJ_EmulSession.autECLPS
          $Oia = $OBJ_EmulSession.autECLOIA
      EndFunc
      ; Send Data to ASW
      ; if $rownum and $colnum are not specified, defaults to the cmd line
      Func aswSend($keys, $rownum = 20, $colnum = 7, $inhibit = 1)
          $Ps.SendKeys($keys, $rownum, $colnum)
          if $inhibit = 1 Then
              While $Oia.InputInhibited <> 0
              WEnd
          EndIf
          $Oia.WaitForInputReady()
      EndFunc
      ; Get Data from ASW
      Func aswGet($row, $col, $length)
          $info = $Ps.GetText($row,$col,$length)
          return $info
      Endfunc
      ; Check which page we are on
      ; @param $page - Page to see if we are on. Ex: "DMR30101" == Sales Order Maintenance page
      Func checkScreen($page, $rownum = 1, $colnum = 72, $length = 8)
          If StringInStr(aswGet($rownum, $colnum, $length), $page) Then
              Return 1
          Else
              Return 0
          EndIf
      EndFunc
      I would like to use it launch a connection to the AS400. I have an executable that I run with an hod file. Do I just need to run the exe and hod file then run the session connect function and send keys function to pass credentials?
       
    • By FordsFinest
      Have come across an issue where I use the below code to select and then click an item. It works great on every computer but one, which happens to be my bosses computer (of course right lol).  So SelectItem works fine, but for some reason, the ClickItem command keeps clicking the item below the correct item (but only on this computer. I changed the command to controlsend instead, but i'd rather use the click option.. any ideas here?
       
      _GUICtrlTreeView_SelectItem($hWnd, $Array2[1]) _GUICtrlTreeView_ClickItem($hWnd, $Array2[1], "right")  
    • By gahhon
      So I had compiled my AutoIT script into executable file, I think like few weeks ago.
      But once after I compiled the script to executable file, I tested it and it work as expected.
      Somehow, I just now wanna try to execute it but failed

      Any idea what's is going on? Do I need to recompile the script again? @@
×
×
  • Create New...