Xichael

How to Set Monospace as Default in SciTE?

7 posts in this topic

#1 ·  Posted (edited)

Whenever I restart the editor, "Use Monospaced Font" (in the Options menu) gets unchecked.

Also, SciTE Config isn't able to switch the font to monospace (though it does successfully save the font face and size), and after restarting it, the font check box is always set back to proportional.

Both of these options are failing to keep SciTE set to monospace. Is there something else I can try?

Edited by Xichael

Share this post


Link to post
Share on other sites



Have you checked whether your SciTE or maybe even just its configuration files are write-protected? Check the read-only flag, the location of those files, and the rights of your windows user. 

Share this post


Link to post
Share on other sites

What I do on my systems is to use the same font for both monospaced and non-monospaced font styles. I never use a non-monospace font so it makes no difference (to me) that I don't have one selected.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Have you checked whether your SciTE or maybe even just its configuration files are write-protected?

use the same font for both monospaced and non-monospaced font styles

SciTE Config is writing changes to the file just fine. Here are the top lines of %LocalAppData%\AutoIt v3\SciTE\SciTEUser.properties after changing both the monospace and proportional fonts:

font.monospace=font:Source Code Pro,size:12
font.base=font:Source Code Pro,size:12

Yet here is a screenshot of SciTE Config's font settings after restarting it:

Screenshot_1.thumb.png.e30c2f6321a64eec2

Only the font.monospace line is being honored. Both SciTE Config and SciTE itself seem to be ignoring font.base line.

Is some other config file overriding this SciTEUser.properties file?

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Do you have this still in your SciTEGlobal.properties:

if PLAT_WIN
    font.base=font:Verdana,size:10,$(font.override)
    font.small=font:Verdana,size:8,$(font.override)
    font.comment=font:Comic Sans MS,size:9,$(font.override)
    font.code.comment.box=$(font.comment),$(font.override)
    font.code.comment.line=$(font.comment),$(font.override)
    font.code.comment.doc=$(font.comment),$(font.override)
    font.code.comment.nested=$(font.comment),$(font.override)
    font.text=font:Times New Roman,size:11,$(font.override)
    font.text.comment=font:Verdana,size:9,$(font.override)
    font.embedded.base=font:Verdana,size:9,$(font.override)
    font.embedded.comment=font:Comic Sans MS,size:8,$(font.override)
    font.vbs=font:Lucida Sans Unicode,size:10,$(font.override)
    font.monospace=font:Courier New,size:10
    font.override=$(font.monospace)

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Yes. I do indeed.

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

When both SciTE and SciTE config do not honer the font.override=$(font.monospace) then I can only assume there is something changed in a config somewhere.

Looking at the 2 lines you've posted again in detail,  I guess you made a manual change for the font.base line which should read:

font.monospace=font:Source Code Pro,size:12
font.base=font:Arial,size:10,$(font.override)

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now