DickG

Compiler options no longer display on F7

21 posts in this topic

I did something wrong, but I have no clue what.  But now, the compile options no longer show when I use F7 or Tools>Compile.

Any idea how to get it back?

Share this post


Link to post
Share on other sites



26 minutes ago, Jos said:

You do have a file open with an .au3 extension?

Jos

Yes. My script is open when I click Ctrl-F7. I used to get the GUI that showed the options, but now it doesn't appear.

Share this post


Link to post
Share on other sites

Are you running the Lite Version of SciTE that comes with AutoIt3 in stead of the Full version that comes with the  separate installer? (Check help/About)

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
5 minutes ago, Jos said:

Are you running the Lite Version of SciTE that comes with AutoIt3 in stead of the Full version that comes with the  separate installer? (Check help/About)

Jos

I'm running the full version of SciTE.

Share this post


Link to post
Share on other sites

Ok, some more checks:

  • do you see all options under the tools dropdown menu? 
  • Have you modified any properties files like au3.properties, SciteGlobal.properties or SciTEUser.properties?

Jos 


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
15 minutes ago, Jos said:

Ok, some more checks:

  • do you see all options under the tools dropdown menu? 

Yes.

  • Have you modified any properties files like au3.properties, SciteGlobal.properties or SciTEUser.properties?

Not that I know of. But those files don't have a more recent date than before.

Jos 

 

Share this post


Link to post
Share on other sites

Does the Tools menu Include "Compile Ctrl+F7"?   
and when yes: what happens when you select it?

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
11 minutes ago, Jos said:

Does the Tools menu Include "Compile Ctrl+F7"?   
and when yes: what happens when you select it?

Jos

Yes it does. It runs w/o showing the AutoIt Wrapper GUI.

However, I just tried compiling a different script, it the GUI appears!!! I have no idea why because did not change any of the compile parameters before that (that I know of -- but it's possible I might have hit some wrong keys to do something like that). So it looks like it's somehow linked to that one script.

Share this post


Link to post
Share on other sites

Show the info from the SciTE output pane when you trying the "Compile with options"and gui isn't showing.
Also specify any "#AutoIt3Wrapper_" directive you have in the script source.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
11 minutes ago, Jos said:

Show the info from the SciTE output pane when you trying the "Compile with options"and gui isn't showing.
Also specify any "#AutoIt3Wrapper_" directive you have in the script source.

Jos

Jos, I just found out the problem: It's a weird one.

I found a backup version of my script that showed the Wrapper GUI, then made a temp file of that. Then I started replacing one section at a time to see if it still shows. I homed in on 4 lines of code that used characters from an HTML that I was trying to delete. They were "â–¶ ". So these lines were causing the problem: (see code)"â–¶ "

;Remove "â–¶ " from any string. This prevents characters above Chr(128) from displaying.
If StringInStr($Bookmark, "â–¶ ") Then
    ;MsgBox(0, $ThisFunc, "Found 'â–¶ ' in " & $Bookmark)
    $Bookmark = StringReplace($Bookmark, "â–¶ ", "")
EndIf

Even if I deleted the If statement but left the commented out line, it still refused to show the Wrapper GUI. But when I replaced the characters with Chr(), it worked! I've never seen anything like this before. What do you think causes this?

Share this post


Link to post
Share on other sites

I cannot replicate your problem when I copy&paste that snippt into a script, so can you pm me a snippet that has the problem?

Jos 


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
1 hour ago, Jos said:

I cannot replicate your problem when I copy&paste that snippt into a script, so can you pm me a snippet that has the problem?

Jos 

Now I can't even replicate that problem. When I put the original lines back, the Wrapper GUI still appears. Sorry. I don't know what's going on with this.

But I think it had to do with opening an HTML file for reading (one that contained those characters in some bookmarks). I am developing a Bookmarks Manager so I can see all my bookmarks from Firefox (or any other Web browser) after I export the bookmarks to an HTML file. I make a tree of one file on the left that shows all bookmarks under their proper folder names, then a tree of another file (from a different computer) on the right. My idea is to be able to manage the bookmarks (add/edit/delete/copy/move/sort/search ...), then write it back to the same or another HTML bookmarks file for import back to the browser.

So maybe you can create a test HTML file with those characters to see how it's handled after it's opened. It would be a lot of trouble for me to do it, especially because my problem seems to be resolved.

But I also noticed that I had been getting notices in the console that said:

"! * Input file is UTF8 without BOM encoded, Obfuscator do not support UNICODE and will be skipped".

But I had no idea what that meant or what to do about it. But that message no longer appears once I used the Chr() versions of those characters.

I appreciate you help on this, Jos. Thanks much.

Share this post


Link to post
Share on other sites
9 hours ago, DickG said:

"! * Input file is UTF8 without BOM encoded, Obfuscator do not support UNICODE and will be skipped".

This warning means you aren't really running a recent version of AutoIt3Wrapper as support for Obfuscator was stopped since  4/5/2014. :)

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
12 hours ago, Jos said:

This warning means you aren't really running a recent version of AutoIt3Wrapper as support for Obfuscator was stopped since  4/5/2014. :)

Jos

Hmmm ... interesting.

I have SciTE4AutoIt3.exe (for AutoIt v3.3.14.2) dated 9/20/2015.

My current AutoIt3Wrapper.exe is dated 1/22/2014 and is v2.1.4.4. Is that the latest version?

Share this post


Link to post
Share on other sites

I tried that link again, and it worked this time.

The file is v15.920.938.0 (from Properties). Is that the correct version? Otherwise, I don't know about what the separate SciTE4AutoIt3 installer is. Can you provide a link for that?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now