Roy_

Scite console panel show weird characters

6 posts in this topic

Hi everybody,

I don't know how, I think starting from yesterday, Scite show weird characters in its console panel.

Maybe I'm missing some configuration.

If I write the following statement:

ConsoleWrite("Cioè" & @crlf)

I get the following output: CioxE8

The source file encoding is UTF8 with BOM.

AutoItVersion 3.3.14.2

Os: Win 7 64Bit 

Os Language: Italian.

Thank you for your help.

Roy.

 

 

Share this post


Link to post
Share on other sites



3 minutes ago, Roy_ said:

I don't know how, I think starting from yesterday

So what did you change? :)

Show me the full output of the SciTE output pane (Console) so I can see what you are using.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Thank you Jos.

Here It is:

>"C:\Program Files (x86)\AutoIt3\SciTE\..\AutoIt3.exe" "C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.au3" /run /prod /ErrorStdOut /in "C:\AutoItObj\examples\pc5250\testutf8.au3" /UserParams    
+>15:16:40 Starting AutoIt3Wrapper v.16.306.1237.0 SciTE v.3.6.2.0   Keyboard:00000410  OS:WIN_7/Service Pack 1  CPU:X64 OS:X64  Environment(Language:0410)  CodePage:0  utf8.auto.check:4    # detect ascii high characters and if none found set default encoding to UTF8 and do not add BOM
+>         SciTEDir => C:\Program Files (x86)\AutoIt3\SciTE   UserDir => C:\Users\roy\AppData\Local\AutoIt v3\SciTE\AutoIt3Wrapper   SCITE_USERHOME => C:\Users\roy\AppData\Local\AutoIt v3\SciTE 
>Running AU3Check (3.3.14.2)  from:C:\Program Files (x86)\AutoIt3  input:C:\AutoItObj\examples\pc5250\testutf8.au3
+>15:16:40 AU3Check ended.rc:0
>Running:(3.3.14.2):C:\Program Files (x86)\AutoIt3\autoit3.exe "C:\AutoItObj\examples\pc5250\testutf8.au3"    
--> Press Ctrl+Alt+Break to Restart or Ctrl+Break to Stop
3.3.14.2
+>15:16:40 AutoIt3.exe ended.rc:0
+>15:16:40 AutoIt3Wrapper Finished.
>Exit code: 0    Time: 0.4789

 

Share this post


Link to post
Share on other sites

Did you see this bit:

# detect ascii high characters and if none found set default encoding to UTF8 and do not add BOM

Seems it takes the whole line in stead of just the number from the SciTEGlobal.properties which I need to fix. :)

Don't think that is the root cause of your issue though because for me it is working fine.
Can you PM me the file your are testing with that just simply contains that one consolewrite line?

Jos 


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

How suggested by Jos,

adding output.code.page=0 in SciteUser.properties solved the problem.

Thank you.

Roy

Share this post


Link to post
Share on other sites

I had a look and have updated the sciteglobal.properties for the next release, to set this as a proper default for windows similar to the setting for "code.page=0"

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now