Sign in to follow this  
Followers 0
tommytx

Selective downloading from one website.

3 posts in this topic

#1 ·  Posted (edited)

Folks I need help real bad.. I think my site has been invaded by a gremlin...

I am using the following autoit code which has worked just fine in the past with this very website.. matter of fact two days ago.

$str = "http://vahud.com/"
Local $dat = _INetGetSource($str)
ConsoleWrite($dat & @CRLF)

So here is how it goes....about a week ago i Ran this code..

$str = "http://vahud.com/idx/zip/12345" and replaced the 12345 with maybe 50 other zip codes and downloaded the 50 files..all is good..

Now the very same program using str=vahud.com/ will not download even the index file.. but works fine on any other site..

Also as long as i get it a specific file it will download from vahud.com/mydir/myfile.txt etc..

the URI I am trying to download all look like this.. /idx/zip/actual zip code or /idx/city/acutal city..

Downloads fine from any other site that has the same idx functional.. but what is odd I cannot even download the / (root index file) but downloads every body elses root..

I have total control over the site as its a VPS even root access.. so no one could block me... maybe the idx provider could block me from the /idx/zip/actual zip but I can download it vai the browser and the very same idx on someone esles site downloads fine..  Every other function of the site works perfectly.



final note.. I have gone into htaccess and blocked several crawlers but trust me I did not add my IP and plus i am not blocked ip wise anyway.. and no one else has access.

 

If i was not blocked from downloading the / I might suspect the idx provider due to too many downloads in a short period.. but since I can view it with the browser my IP must be fine.

Any thoughts, suggestions that i might try would be appreciated..

 

 

 

 

 

Edited by tommytx

Share this post


Link to post
Share on other sites



The site design has changed. So you must explore to find the correct urls for downloading the wanted infos.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Nope the url direct /idx/zip/12345 works fine and going to the same /idx/ on another website works fine...they both use idenitcal ursl with exception of the domain name changes... Plus that would have nothing to do with the fact that i can no longer download the root... / on my site but can on any other site.. and I surely did not change my on site... basically none of it makes any sense at all... should not be happening.. but thanks for the suggestion.

 

 

 

Edited by tommytx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0