Sign in to follow this  
Followers 0
Chimaera

Having trouble with running bcdedit

3 posts in this topic

Hi all im trying to make a button set a machine to start in safe mode

using bcdedit which seems to be the best and easiest way but

It doesnt work and im scratching my head as to why

Ive tried with admin/without admin/compiled and a load of stuff, but no joy

Case $hButton_3
;~              bcdedit /set {current} safeboot network
;~              Run(@ComSpec & " /c " & 'bcdedit.exe /set {current} safeboot minimal', "", @SW_HIDE) ; >' & @AppDataDir & '\Toolz\savelog.txt'
;~              bcdedit /set {current} safeboot minimal
;~              Run('bcdedit /set {current} safeboot minimal')
                Local $test = Run(@ComSpec & " /k " & 'bcdedit.exe /set {current} safeboot minimal', 'C:\Windows\System32', @SW_SHOW)
;~              RunWait(@ComSpec & " /c " & "bcdedit.exe /set {current} safeboot minimal")
                MsgBox(64, 'test', $test)

I even tried making it look at 64 bit just in case 

C:\Windows\Sysnative\bcdedit

The error i get is this in the command window but bcdedit is definitely in the folder

test.png

Can anyone suggest where i might be going wrong?

 

Share this post


Link to post
Share on other sites



Hi.

See this posting (sysnative)

regards, Rudi.


Earth is flat, pigs can fly, and Nuclear Power is SAFE!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0