searching1

Skype autologin

4 posts in this topic

#1 ·  Posted

Hi All,

Can we automate auto login in skype using autoit? 

saw this script?

Local $USERNAME = ""

$USERNAME = IniRead(@ScriptDir & "\Username.ini", "Section_1", "Skype_Address", "")

While $USERNAME == ""
$USERNAME = InputBox("Skype Login", "Type the your account's username of Skype:","","")
if @Error > 0 Then Exit
MsgBox(64,"INFO","At the next login, your username will be stored in Username.ini and it will not required to type it anymore.")
Wend

IniWrite(@ScriptDir & "\Username.ini","Section_1", "Skype_Address", $USERNAME)

Local $PASSWORD = ""

While $PASSWORD == ""
$PASSWORD = InputBox("Skype Login", "Type the your account's password of Skype:", "", "*")
if @Error > 0 Then Exit
Wend

If @OSArch <> "X86" Then

ShellExecute("Skype_X64.bat",$USERNAME & ' ' & $PASSWORD,@ScriptDir & "\Src","open",@SW_HIDE)


Else

ShellExecute("Skype_X86.bat",$USERNAME & ' ' & $PASSWORD,@ScriptDir & "\Src","open",@SW_HIDE)

Endif

should i replace sky.bat to skype exe? sorry new to auto it and creating script thanks

Share this post


Link to post
Share on other sites



#2 ·  Posted

HI

A simple google search, told that skype have removed the username and password command lines in v7.16

Though I just tried with v 7.33 and the /username:USERNAME still works.

The same google result also gave this AutoIT script

RunSkype('username', 'password')
;RunSkype('username2', 'password2') ; Can run as many as you need.
Exit

Func RunSkype($username, $password)
    Run('Skype.exe /secondary /username:' & $username)
    WinWaitActive('Skype')
    Sleep(4000) ; Might need to increase this on slow PCs
    local $hWnd = WinGetHandle("[CLASS:TLoginForm]", "")
    If Not @error Then
        ControlSend($hWnd, "", "[CLASS:Internet Explorer_Server]", $password & "{ENTER}")
    EndIf
EndFunc

I haven't tested the script, but it might help you in the way

 

Cheers
/Rex

Share this post


Link to post
Share on other sites

#3 ·  Posted

Hi Rex,

My result was same as yours. Only username. but password Cannot haha. 

Mine is v23.

Thank you

Share this post


Link to post
Share on other sites

#4 ·  Posted

Hi there,

I wrote that script initially.  Its been updated a few times over the months as Skype keeps changing how their forms work.  Here's the latest iteration that works as of the update it installed for me today (Skype Version 7.36.0.101):

RunSkype('username1', 'password1')
;RunSkype('username2', 'password2') ; Can run as many as you need.
Exit

Func RunSkype($username, $password)
    Run('Skype.exe /secondary /username:' & $username)
    WinWaitActive('Skype')
    Sleep(6000) ; Might need to increase this on slow PCs
    local $hWnd = WinGetHandle("[CLASS:TLoginForm]", "")
    If Not @error Then
        ControlSend($hWnd, "", "[CLASS:Edit]", "{ENTER}");
        Sleep(2000) ; Might need to increase this on slow PCs
        local $hWnd = WinGetHandle("[CLASS:TLoginForm]", "")
        If Not @error Then
            ControlSend($hWnd, "", "[CLASS:Internet Explorer_Server]", $password & "{ENTER}")
        Endif
    EndIf
EndFunc

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now