frew

Script not Sending to SciTE now, wondering why

9 posts in this topic

#1 ·  Posted (edited)

Hello,

I just do real basic play with scripts to automate some simple tasks.

I have the following four lines in a simple .au3 that I run with a hotkey,

It's a kind of little macro that I use often because I tend to put lots of little sleeps in my scripts.

For example, I may type something like

$Rand = Random(3, 7, 1)

then hit Ctrl+Shift+a to run a script with these four lines in it.

Send("{End}")
Send("{Enter}")
Send("Sleep(500)")
Send("{Enter}")

For some reason that is not sending to SciTE as I'm editing a file in SciTE.

It used to work fine, but upgraded to Windows  10 and latest AutoIt3, and latest SciTE,

and now for some reason the script is not sending to SciTE.

It sends fine to other text editors.

Thanks for any ideas.

frew

edit...gotta hit the hay, but thanks for any ideas...will check back tommorrow

Edited by frew

Share this post


Link to post
Share on other sites



#2 ·  Posted

Have a look to ControlSend and the other Control.. commands. To use "Send" should be the last try.


Best Regards BugFix  

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

7 hours ago, BugFix said:

Have a look to ControlSend and the other Control.. commands. To use "Send" should be the last try.

I tried ControlSend and still does not work. Thanks for the idea to try.

 

2 hours ago, Xandy said:
#RequireAdmin

 (I put it at top of script) to gain authority to Send to keystrokes in Windows10

Yes, that works. Thank you.

On a perhaps related subject, I use PowerPro too, and I have a key combination set up in PowerPro (Ctrl+Alt+V) that opens up a clipboard

of 20 or so recent text clips I can choose from. This had worked fine in SciTE until Windows 10, and the most recent AutoIt and SciTE,

and now it does not work when editing in SciTE. It does still work fine when editing in other text editors though.

Any ideas why it may not be working in SciTE?

edit: I just get a paste in SciTE as if I'm doing a Ctrl+V, whereas I'm doing a Ctrl+Alt+V

Thanks.

Edited by frew

Share this post


Link to post
Share on other sites

#6 ·  Posted

nice to know it right now.

THX for the important information

Share this post


Link to post
Share on other sites

#7 ·  Posted

2 minutes ago, Verssuss said:

THX for the important information

I try so hard.

Share this post


Link to post
Share on other sites

#8 ·  Posted

Okay so the not sending problem solved by putting

#RequireAdmin

into the top of the script that's doing the sending.

 

The PowerPro hotkeys combinations I set up that did not work in SciTE is solved by going into

PowerPro config> keys> setup> key interception method> and changing it to Legacy 2.

I'm not really sure what all that means, but it all works now.

Maybe it says something about how SciTE recognizes keys, or key combinations?

I really have no idea.

Thanks for the help and ideas.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now